0

I'm trying to install the CiviVolunteer extension (Drupal 7, Civi 5), but am getting this error message in response:

Field: name must be unique. An conflicting entity already exists - id: 186

It looks like the developer had previously installed and enabled the extension, but then manually deleted it, without also removing the CiviVolunteer data from the database.

Any suggestions for how to clean up the leftover CiviVolunteer data, or another way that I can reinstall the extension?

  • UPDATE -

No luck with executing the mysql commands (cannot find tables), and unable to reinstall the CiviVolunteer extension (which is ultimately what I'm after). Receiving the same error message as above, and this screen when I return to the extensions page:

enter image description here

2

This is going to sound weird, but what you need to do is add the extension files back into the extensions directory. Then refresh the extensions page so that it doesn't show that it is missing.

If you don't want to keep it or get an error still, after that, then next enable it again and let us know if you get an error message and what it is. From there, you can disable and uninstall it again and remove the extension files.

  • No luck. Even after removing CiviVolunteer values from the database, I get this error message: "'339' is not a valid option for field option_group_id". Looks like installation is getting hung up on one option group... – Adam May 9 '18 at 14:52
  • It's tough to say. If you've already begun doing work on the database on the MySQL side, things could be a bit complicated, with missing parts. It might be beyond the scope of this. (edited old comment) – Christia May 9 '18 at 22:33
2

You could try having a look at the volunteer_uninstall.sql file?

https://github.com/civicrm/org.civicrm.volunteer/blob/master/sql/volunteer_uninstall.sql

2

OK. Had to manually delete all CiviVolunteer tables, values, etc. from the database, clear caches, completely remove the extension, and then download and install through the admin. Decidedly unsexy, but worked.

  • 1
    You should be able to 'accept' your own Question, if not immediately, in a while. – petednz - fuzion May 9 '18 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.