I want to install extensions which are not listed in the "Add Neww" directory, such as :

  • de.systopia.osm-1.2
  • net.ourpowerbase.exportpermission-master

I copied those (from their Git source) to my Site Extension directory, but they don't appear in my Extensions list, so, I cant activate them.

How can I activate them ?

  • Have you tried hitting the refresh button on the extension page? May 7, 2018 at 11:47
  • 2
    As a tip - rename the folders to de.systopia.osm and net.ourpowerbase.exportpermission. Otherwise the folders will have the same names when the extensions are upgraded, which will be confusing. May 7, 2018 at 13:32

3 Answers 3


Here is the documentation from the administrator guide: https://docs.civicrm.org/sysadmin/en/latest/customize/extensions/#installing-a-new-extension

There are three steps:

  • Upload extension package
  • Extract (Unzip) the package
  • Install and enable the extension, you should refresh your extensions page to show the new extension.

Hope this helps.

  • 1
    Would be good to add jon's note about renaming extension. also i would recommend 'and then remove the .git file from the extension' to avoid git problems down the track for those using git
    – petednz - fuzion
    May 7, 2018 at 19:53

The other suggestions are good. If one is a fan of CLI, then cv provides a few easy options.

Download a published extension from the directory (long name).

cv dl org.example.foobar

Download a published extension from the directory (short name).

cv dl foobar

Download an unpublished extension (long name and zip URL)

cv dl org.example.foobar@http://example.org/files/foobar-1.2.zip

Download a pre-release (alpha/beta) from the directory.

cv dl --dev foobar

Note: By default, all these commands will download to the configured extensions folder, use a sensible subfolder (e.g. sites/default/files/civicrm/ext/org.example.foobar), and refresh the ext list. You can download to an alternate location ( --to=<absolute-path>).

  • For some reason, the GDPR extension can be found at civicrm.org/extensions/gdpr/25 but doesn't show up on the "Admin Extensions" page of my drupal/civi4.7 site (even after refresh). But with cv dl uk.co.vedaconsulting.gdpr@https://github.com/veda-consulting/uk.co.vedaconsulting.gdpr/archive/v2.5.zip it's installed with just one command. - Thanks! May 17, 2018 at 2:06
  • Glad the full URL worked. Note: To show up on the in-app "Admin Extensions" UI for automated download, there's a Formal Review, and (at time of writing) that extension isn't flagged as reviewed. So you have use the URL or --dev
    – Tim Otten
    May 17, 2018 at 19:06

I apologize : I found that I have some jam in my Extension directories : my extensions files are not in the directory specified for (civicrm/ext by default), but in an other (probably to be able to update civicrm without loosing the Extensions).

But, what was unexpected is that refreshing listed this old list while it should have listed an empty list.

I have to put some order in there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.