1

Drupal 7.59 Civi 4.7.27

In Blocks there is a default CiviCRM Contact Dashboard. #block-civicrm-3 I have assigned it to Content. It displays for Admin but not for any other roles. I want it to display for role Donor. In the block config I have Roles checked to display Admin & Donor.

Under Civi > Administer > Users > Permissions > Drupal Access Control I checked for Donor: CiviCRM: view my contact & CiviCRM: access Contact Dashboard

But the Donor role still cannot see the link to access their dashboard. When signed in as a donor I can go to /civicrm/user and see the dashboard. It is just not displaying this default block that has the link.

Any ideas what is keeping this from displaying?

1

The default contact dashboard block is only visible on civicrm pages or form. If the user has access CiviCRM permission than on /civicrm it should display the block or you can change the setting by editing the block to include it on all the pages.

Hth

Pradeep

  • I am trying to view it on a Civi contribution page. I have the block setting to display on civi and civi/* It displays there for Admin but not other users, which shows that it can display where I want it. – Iowa Boy May 8 '18 at 0:27
  • The code says it requires 'access CiviCRM' permission for user to see the 'View Contact Dashboard' block. (Ref: github.com/civicrm/civicrm-core/blob/master/CRM/Core/…) – Pradeep Nayak May 8 '18 at 6:56
  • Now that I understand what you are saying, yes this is correct. Checking Access CiviCRM needed to be checked in user permissions. Your answer is correct for my question, but I am still sticking with my fix of creating my own link. The problem is that with this fix, donors can search Civi Contacts and see everyones contact info, activity, etc. With my solution, I do not need to give them Access CiviCRM. I double checked, in permissions I had checked View My Contact and not View All Contacts. – Iowa Boy May 9 '18 at 15:05
  • Yup agreed the link doesn't need Access CiviCRM permission but the block does need. Giving access CiviCRM permission may user have access to most of the links. Creating separate block is a good idea. – Pradeep Nayak May 9 '18 at 15:32
0

I created a new block with with the link civicrm/user and assigned it to role Donor and it shows up. Not sure why the default one does not show up, all the settings are the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.