2

I've followed all the instructions according to this documentation but when I test the incoming SMS', I do not see the SMS's coming into CiviCRM.

Below are the settings I have set up in Telerivet and then copied to Civi

These are the API keys

This is the Webhook settings This is the Webhook

And here I would expect to see the option to send an SMS

enter image description here

I also would like to see where the incoming SMS would come into. According to the video, a report can be set up to show all the incoming SMS's but I cannot seem to create the same report.

2

For sending sms, the contact should have Phone number of phone type as 'Mobile' and Primary as true. The option will be visible once you set required phone type.

The incoming message will be shown under Activity tab of Contact of Activity type as Inbound SMS. You can also check using Activity search with filter Activity type as Inbound SMS. You can also create Activity report with with filter Activity type as Inbound SMS and have it available on dashboard.

HTH

Pradeep

  • Thanks Pradeep. Adding the number as an Mobile number worked however, I still cannot send or receive the SMS's. Could this be due to the account being in Test Plan mode? – SixfootJames May 8 '18 at 14:00
  • Did you got any error? – Pradeep Nayak May 8 '18 at 14:04
  • And are the relevant cron jobs enabled? – Jaap Jansma - CiviCooP May 8 '18 at 14:24
  • @JaapJansma - no cron jobs are necessary for the SMS workflows outlined above. They are only needed for sending scheduled mass SMS. – michaelmcandrew May 8 '18 at 16:20
1

Pradeep has covered a couple of the issues already, but for the sake of completeness:

here I would expect to see the option to send an SMS

Ensure that the contact has a phone of type 'mobile'

I also would like to see where the incoming SMS would come into

An Activity report filtered by activity type Incoming SMS should do the trick

This is the Webhook settings https://crm.helderberghospice.org.za/civicrm/sms/callback

I tested that URL and it came back with "Page not found". It looks like you are using Wordpress, in which case the form of callback URL is different. Based on this answer and your existing callback, I suspect that your webhook should be:

https://crm.helderberghospice.org.za/?page=CiviCRM&q=civicrm%2Fsms%2Fcallback&provider=org.ndi.sms.telerivet

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.