1

Quick question - is there anything in particular to take into consideration when upgrading Drupal, if it is used as a platform for CiviCRM?

Or can I just go ahead with Drupal update as if there was not CiviCRM installed?

  • pls clarify what you mean by 'update' – petednz - fuzion May 11 '18 at 19:26
  • In this case I meant minor version upgrade. – Aivars May 15 '18 at 17:51
  • @Aivars - if one of the answers below answers your question can you accept the answer using the "Tick" button? – HomoTechsual May 17 '18 at 20:58
7

It depends on the upgrade i.e from 6.x to 7.x to 8.x. If its a simple and internal version i.e 7.12 to 7.29 than you can perform update directly and you won't have problem in CiviCRM but if its from 6 to 7/8 then you will need to replace the CiviCRM files with same version for D7 or D8 and then clear CiviCRM cache(probably delete template_c).

Note: Backup Database and filesystem before performing upgrade.

2

You should be able to upgrade within a major version (7.x to 7.x) (6.x to 6.x) (8.x.x to 8.x.x) of Drupal without experiencing any major issues however as with any upgrade it is recommended to take a full backup before you attempt the upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.