1

Running CiviCRM 4.7.31 on WordPress 4.9.5. When attempting to edit an existing membership type, I am receiving an error "Network Error: Unable to reach the server. Please refresh this page in your browser and try again." I refresh and get the same result. All other parts of CiviCRM are working fine. Any help is appreciated.

enter image description here

  • Is this a regular instance or multisite? – Andy Burns May 12 '18 at 22:32
  • Hi Andy. Regular instance. No multisite – Nicholas DeCenzo May 13 '18 at 3:06
  • Did you set CiviCRM in Debug mode? If not, enable it and report if there were any extra messages and/or the content of any created error log file – ñull May 18 '18 at 11:24
  • Please also check browser's JS console to have a glance at ajax errors. – nielo May 20 '18 at 17:20
1

With such issues it is worth trying a 'right click' on the link to open the Edit screen as you may get to see an error message that you don't see with the pop up. If you find one, the repost in your Q

  • Hi, when I 'right click' on the link to edit the membership type, I get this error message : "Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Constraint Violation - membership_contact_id should possibly be marked as mandatory for Membership,get API. If so, please raise a bug report." – Nicholas DeCenzo May 13 '18 at 3:27
  • You could take a look in your ConfigAndLog files, or if that is trickier for you than adding an Extension you could add the Log Viewer extension civicrm.org/extensions/civicrm-log-viewer - and see if that gives you more info – petednz - fuzion May 13 '18 at 20:36
  • I get the exact same error when I try to edit a membership. I am also running Civi 4.7.31 on Wordpress. Right clicking and opening in a new window, gives me "Fatal error: Call to undefined method CRM_Contribute_Task::taskTitles() in /home/mysite/www/www/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Task.php on line 163" Has there been any luck with finding the root cause? – Sudesh Oct 4 '18 at 11:43
  • unless you can show that this problem is still occuring on latest civicrm then it is unlikely effort is being put in to finding a fix for an older version of civicrm – petednz - fuzion Oct 4 '18 at 19:07
  • also confirm if you have any warnings/errors eg Resource urls etc – petednz - fuzion Oct 5 '18 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.