0

we are trying to upgrade a CiviCRM 4.6.15 on Wordpress that comes from a multisite Drupal installation. This on WordPress is on a different server, but with the same DNS and Admin name. It works correctly but...

...if we try to upgrade to CiviCRM 4.7 (or 5.1) the procedure starts but does not go beyond a "dead screen" with a Retry & Skip button that do not work.

We fear that there were problems with exporting the DB from Drupal multisite. Please, where should we look for the error?

Attached the log file: https://pastebin.com/65fnAgMG

Thanks in advance for those who can help us.

UPDATE:

1) as our SysAdmin (user3225453) replied, we've tried to follow Jaap's procedure below, but it's not working.

2) However this activity and the next Jaap' comment helped us to read better the LOGs:

the problem (if does not concern "not imported custom fields" as suspected by Jaap) could also be related to "PROFILE" (aka: "UF_Group", which are also found in the LOG)

Do you have any idea? what about if we delete all profiles from the previous installation and try a new update?

Thx.

  • 1
    Can you check CiviCRM log file if there are any errors? – Pradeep Nayak May 16 '18 at 14:30
  • Yes, logs under ConfigAndLog folder. – Pradeep Nayak May 16 '18 at 19:18
  • Did you run a perl script to sort out the triggers when you imported the sql dump? – petednz - fuzion May 17 '18 at 10:12
  • i've tried to follow Jaap's procedure, but it's not working. I've tried to search the log when i do upgrade and get this. pastebin.com/65fnAgMG Any help will be appreciated. – user3225453 May 17 '18 at 17:15
  • 1
    Please see the answer below. "user3225453" is our SysAdmin – Alessandro Letizia May 17 '18 at 19:31
2

we were able to update CiviCRM from ver. 4.6.18 to version 5.2.1! I will tell you below how we solved the problem:

a) we realized that we had 3 extensions (CiviVolunteer + Angular + CiviRules) that we did not use. CiviRules, in particular, needed updates (a Yellow Warning said us that it was necessary to update the DB, but the relative link did not work);

b) then we unistalled all the extensions and canceled the relative permissions in Wordpress Access Controll.

c) we cleaned up and verified that no traces were left.

The upgrade was successful.

It must be said that we had installed the three extensions for testing purposes, but if they were in production ... :(

1

Without seeing the log files or the error message. My guess is that has to do with exporting the database and importing it. When you export a database mysql adds 'DEFINER=...' to triggers. That definer is the database user in your old database, when you import the database it all goes fine, till the database trigger gets fired.

To fix this do the following:

  1. export the database from your new site
  2. If your are on on linux run the following command: sed -i 's/DEFINER=[^*]*\*/\*/g' mydump.sql This will remove the definer statements from the dump.
  3. Import the database again

For step 2 see https://stackoverflow.com/a/24613430/3733632

0

It seems the excellent answer from @Jaap_Jansma will solve the issue with the DB import. The missing field error which occurs is due to a missing field which is part of the multilingual schema.

As the issue is with a missing frontend_title it would appear that your CiviCRM instance is running in "multilingual" mode. Can you run the following command to rebuild the multilingual schema (replacing "en_US","fr_CA" with the values for the enabled languages on your CiviCRM instance. Pick the right command for the CMS you are using.

Drupal 7

Requires DruSH

drush php-eval 'civicrm_initialize(); CRM_Core_I18n_Schema::rebuildMultilingualSchema(["en_US","fr_CA"], NULL);'

Drupal 8

Requires DruSH

drush php-eval '\Drupal::service('civicrm')->initialize(); CRM_Core_I18n_Schema::rebuildMultilingualSchema(["en_US","fr_CA"], NULL);'

WordPress

Requires WP-CLI

wp eval 'civicrm_initialize(); CRM_Core_I18n_Schema::rebuildMultilingualSchema(["en_US","fr_CA"], NULL);'

Source/Discussion/More Info: https://gist.github.com/mlutfy/647e6325a09079e4f08f273af64900d9

  • Hi, @Homo Techsual, what you say is strange because this CiviCRM did not work in multilingual mode. However we tried and it gives us error: >> "Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: unknown error << Have you another idea? Thx. – Alessandro Letizia May 21 '18 at 16:20
  • Can you provide a backtrace from that error? – HomoTechsual May 21 '18 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.