If the Civi user isn’t logged into their account then they get the following error when clicking token inside their email footer:

Sorry, due to an error, we are unable to fulfill your request at the moment. >

You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.

A fatal error was triggered: is not of type Text

Return to home page.

The link being generated in the mailing is:


Is this expected behavior?

  • Can you include an example of the link which is being placed in the footer? Replace the URL with "example.com", also replace any Contact ID or Checksum present in the URL (<CID> and <CHECKSUM> would work to replace where these are printed in the URL) Commented May 17, 2018 at 21:00
  • It’s just the url generated by the system with a checksum that shows as a hyperlink in the email. You want that whole string? It works and shows a confirm form only if I’m logged into the drupal account but if I click log out then go back to the email and click the hyperlink then I get a horrible error that is super unfriendly to the end user. I’d rather it just instructed them to log in before hand. Commented May 17, 2018 at 21:05
  • This is the url: example.org/civicrm/mailing/… Commented May 17, 2018 at 21:07
  • Thanks @WebmasterTheCMG can you provide the CiviCRM and Drupal versions and confirm that anonymous users have the CiviMail: access CiviMail subscribe/unsubscribe pages permission on the Admin -> People -> Permissions screen in Drupal? Commented May 17, 2018 at 21:27
  • 1
    Can you try disabling the CiviAlerts extension - this is known to cause problems for unauthenticated users (github.com/mr-vara/me.vara.civialerts/pull/1) Commented May 17, 2018 at 22:14

1 Answer 1


I figured it out with the help of the back trace from the error.

It was the CiviAlerts extension which I had installed apparently, I really liked this CiviAlerts too because it let me give my mail admins a message window to see when I wanted all of them to do something differently (like use a different smart group for example in a mailing).

Anyway I just went in and turned off that Extension then redid my test and guess what? The form showed up with the email (and a few asterisks) and a confirmation page. Problem solved. Thanks for the assistance.

The changes described in this Pull Request for the CiviAlerts extensions should resolve the issue: https://github.com/mr-vara/me.vara.civialerts/pull/1

  • 1
    No problem - if you implement the changes from this PR (github.com/mr-vara/me.vara.civialerts/pull/1) you can re-enable the CiviAlerts extension. Commented May 17, 2018 at 22:18
  • How do I implement these changes? I am baffled how to do it, I tried CLONE and that does not get the changes. And I do not have a very good understanding of GIT Commented Jun 13, 2018 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.