2

Selecting Events -> Find Participants under CiviCRM 5.1.2, Joomla 3.8.8, PHP 7.2.5 under IIS displays the event ID and not event name in the Event Name field. This is a bug introduced after 4.7.31. It may be relevant, but the CiviCRM menu drop downs also disappear.

4.7.31:

enter image description here

5.1.2:

enter image description here

I've tried looking at what has changed, but the obvious files aren't showing any such changes.

3
  • 2
    I couldn't replicate the issue on 5.1.2. Could try after deleting template_c and also clear CiviCRM cache Commented May 22, 2018 at 20:11
  • Strange, I cleared the caches and everything under ../media/civicrm/templates_c except the directory en_GB, but to no avail. I even reset the custom paths to eliminate custom code. Are you sure it was on a Joomla instance that you tested it? Commented Jun 3, 2018 at 8:11
  • Has anyone tried the update under Joomla? I updated a local Drupal installation and the problem doesn't appear. Is that why @PradeepNayak couldn't reproduce the problem? Is Joomla still supported, or should we move our CiviCRM environment to Drupal? Commented Jun 14, 2018 at 8:20

1 Answer 1

1

This is related to a general issue with updating CiviCRM under Joomla in a non-US environment, where the views are not updating correctly. The error was only flagged up when I tried to create an event. This pointed me to the log file that then showed what the issue was.

I solved the issue by adding the following lines to the definition of, in our case, the view civicrm_uf_group_en_GB:

   `civicrm_uf_group`.`frontend_title_en_GB` AS `frontend_title`,
    `civicrm_uf_group`.`cancel_button_text_en_GB` AS `cancel_button_text`,
    `civicrm_uf_group`.`submit_button_text_en_GB` AS `submit_button_text`

It seems that the update process isn't applying that change. My knowledge of the update process isn't sufficient to work out how to do it automatically.

2
  • Are you certain this is Joomla related rather than multilingual related?
    – petednz - fuzion
    Commented Jun 19, 2018 at 19:50
  • You are probably right - it is multilingual related, but it may have manifested itself in Joomla rather than Drupal (or maybe it is because I was upgrading from a much older system in Drupal). In general, I have seen a number of issues in the views after upgrading to a new version of CiviCRM which have required manual intervention. Commented Jun 22, 2018 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.