1

Wordpress 4.9.6, CiviCRM 5.1.2. Logged in as Administrator, all works fine (Events links, TEST Contribution page) but LIVE Contribution pages: gives just blank page. Nothing in php.error.log, Apache error_log. ConfigAndLog/* repeatedly says something about "access to page" which, perhaps, is not relevant for WP "super-user".

Deep googling has brought a few of same cases, each of them has own cause, so there is no pattern. Any chance this is a well-known issue in the latest versions of CiviCRM / WordPress? Thanks!

#0 /public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(381): 
CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /public_html/wp- 
content/plugins/civicrm/civicrm/CRM/Utils/System/WordPress.php(350): 
CRM_Core_Error::fatal("You do not have permission to access this page.")
#2 /public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/System.php(74): 
CRM_Utils_System_WordPress->permissionDenied()
#3 /public_html/wp- 
content/plugins/civicrm/civicrm/CRM/Event/Page/EventInfo.php(58): 
CRM_Utils_System::__callStatic("permissionDenied", (Array:0))
#4 /public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(309): 
CRM_Event_Page_EventInfo->run((Array:3), NULL)
#5 /public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(84): 
CRM_Core_Invoke::runItem((Array:15))
#6 /public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(52): 
CRM_Core_Invoke::_invoke((Array:3))
#7 /public_html/wp-content/plugins/civicrm/civicrm.php(1246): 
CRM_Core_Invoke::invoke((Array:3))
#8 /public_html/wp- 
content/plugins/civicrm/includes/civicrm.basepage.php(141): 
CiviCRM_For_WordPress->invoke()
#9 /public_html/wp-includes/class-wp-hook.php(286): 
CiviCRM_For_WordPress_Basepage->basepage_handler(Object(WP))
#10 /public_html/wp-includes/class-wp-hook.php(310): WP_Hook-> apply_filters(NULL, (Array:1))   
#11 /public_html/wp-includes/plugin.php(515): WP_Hook->do_action((Array:1))
#12 /public_html/wp-includes/class-wp.php(726): do_action_ref_array("wp", 
(Array:1))
#13 /public_html/wp-includes/functions.php(960): WP->main("")
#14 /public_html/wp-blog-header.php(16): wp()
#15 /public_html/index.php(17): require("/public_html/wp-blog-header.php")
#16 {main}
  • I see in the log something about permission denied. And I see you are trying to signup for an event. Is that correct? If so is the event public? – Jaap Jansma - CiviCooP May 24 '18 at 7:50
  • @JaapJansma Thank you for note: perhaps these lines aren't even relevant, because it is a Contribution page/form which doesn't work. What puzzles me the most is, there is absolutely no traces in whatever logs I've tried to check (which may mean I haven't found the right log amongst php_error, apache_error, civicrm_log: just running out of ideas where else to look). – yurg May 24 '18 at 9:52
  • @JaapJansma Found this: Events overview page doesn't work either (civicrm/?page=CiviCRM&q=civicrm/event/ical&reset=1&list=1&html=1), yet it leaves at least traces in log, while this Contributions mystery is totally silent. – yurg May 24 '18 at 10:15
  • Maybe it is a good idea to start with the events overview page and find out if you could trace it back to something which makes sense. Did you try to clear the civicrm caches and templates_c dircetories? – Jaap Jansma - CiviCooP May 24 '18 at 11:29
1

By testing on the wpmaster.demo.civicrm.org site and going to what i take it is the public version of the contribution page at eg

http://wpmaster.demo.civicrm.org/civicrm/?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=4

I do not get a blank page which suggests several things including that it isn't broken on dmaster.

Some possible things to try

  • switching WP themes
  • using Inspect to compare output on demo v your site

Not sure how much either will help as not a WP specialist

  • Thank you for pointing to "wpmaster" demo instance, seems my issue is local, something hosting or WP config related; I'm not a WP guru either, wish it was Drupal, where I know how to debug, at least. This silent white page just drives me crazy, there have to be traces! – yurg May 24 '18 at 9:55
  • 1
    In the past, I've had similar things happening to Contribution pages. I found that occasionally, there were conflicts with CiviCRM and other Wordpress plug-ins. It might be worth you deactivating any other plug-ins that you have, one by one, to see if the problem goes away. One plug-in that conflicted for me a couple of years ago was Jetpack – peterb May 31 '18 at 12:24
  • @peterb This is exactly what has happened: still not sure which WP plugin caused the issue, yet disabling a bunch of them makes problem gone. Perhaps, it was one of "security/firewall" WP extensions installed. – yurg May 31 '18 at 15:01
  • yurg maybe worth systematically switching each off/on to identify exact one – petednz - fuzion Jun 1 '18 at 2:26
  • also if this answers your question then pls Accept it so that it is closed off – petednz - fuzion Jun 5 '18 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.