1

My Specs

I migrated a production Drupal 7/Civicrm 7.x-4.7.9 site to my local machine. For my stack, I am running MAMP and PHP 5.6.32, the production server is on PHP 5.6.33

I downloaded all files, and databases (there are two, one for Civicrm and one for Drupal 7).

Took a while, but got it set up and running and changed all urls in the DB. no issues so far.

but now when I got to ...site\civicrm (yes for some reason the local is running on two back slashes in stead of one -- if this is an issue, otherwise it's secondary to the below unless related...)

And here is what I need help with:

I get this error:

Sorry but we are not able to provide this at the moment. 'civicrm/showevents': Could not find access_callback in path tree, Could not find page_arguments in path tree, Could not find is_ssl in path tree


Things I've done so far: Cleared all cache

Any thoughts?

Thanks in Advance!!!

  • Make sure you have correct path values set in Administer -> System Settings -> Resource URLs and Administer -> System Settings -> Directories – jitendra - fuzion Jun 4 '18 at 8:38
  • If you click on the Question mark on the "directory" page make sure that the path it shows corresponds to your local file system as well. If it doesn't you might need to edit your civicrm.settings.php file. – Luke Stewart Jun 5 '18 at 4:43
  • I agree with @jitendra-fuzion and also check $civicrm_root variable and variable for templates_c directory in civicrm_settings.php file. Also Check if your DB credentials are correct according to localhost – Hassan Farooq Jun 5 '18 at 18:57
  • @jitendra-fuzion, the administer section would this be found in the civicrm settings in the back end? if so, I can't actually get to the admin page of civi -- I get the same error : Sorry but we are not able to provide this at the moment. 'civicrm/showevents': Could not find access_callback in path tree, Could not find page_arguments in path tree, Could not find is_ssl in path tree – Manu Jun 5 '18 at 20:18
  • @HassanFarooq and luke Stewart, I checked both civi and db credentials... everything is populating right and now the double slash is gone (there was a trailing slash in settings.php). I've been playing with different things that could be the $civicrm_root and the c directoy, no luck yet though... – Manu Jun 5 '18 at 21:53
0

The path civicrm/showevents does not seem to be a part of core. I think you have an extension enabled on your site which is creating a problem.

  • Disable or uninstall Event Calendar(com.osseed.eventcalendar) from Extension page civicrm/admin/extensions?reset=1.
  • If you can't access the extension page, try disabling this using cv command OR directly modifying civicrm_extension table in your database. Set is_active value to 0.

    $ cv ext:disable com.osseed.eventcalendar
    
  • Clear cache OR rebuild the menu using civicrm/menu/rebuild?reset=1.

  • I think you nailed it -- the Event Calendar is an extention. I followed your advice and went into the database (via PhpMyAdmin) and set the civicrm_extension tables is_active to zero. but now now I am getting a " The page isn’t redirecting properly" Error with " his problem can sometimes be caused by disabling or refusing to accept cookies." --looking into this now – Manu Jun 7 '18 at 19:15
  • and I am also getting this error... in dblogs for drupal, I think they might be related... Warning: opendir(localhost:8888/drupal/sites/all/modules/civicrm/CRM/Campaign/…): failed to open dir: not implemented in CRM_Utils_File::getFilesByExtension() (line 438 of /Applications/MAMP/htdocs/drupal/sites/all/modules/civicrm/CRM/Utils/File.php). – Manu Jun 7 '18 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.