1

I’ve been using CiviCRM for half a year now and I think it’s great. There is just one thing that does not work quite right: When I add a membership/contribution to a user, both get recorded in the database but they don’t show up immediately. I have to wait a day or so for them to display correctly. I attached 3 screenshots: When I click on Summary, the „Contributions“ and „Memberships“ registers show that Contributions/Memberships have been added. But as soon as I click on them, they get greyed out and don’t show anything. Interesting enough, if I change other member details (name, address, etc.), the changes are shown immediately. I already tried clearing Joomla’s and CiviCRM’s caches but no success.

Does anybody know why this is happening?

Thank you very much in advance!

cejavila

PS: I was on 4.7.29 and am now on 5.1.2 (thought the update might help, but nope)

enter image description here

enter image description here

enter image description here

  • This sounds odd and is def. not how civicrm functions. When you add a Membership, does it then show under Find Memberships? – petednz - fuzion Jun 5 '18 at 21:51
  • This really sounds odd. I would checkout the permissions on the templates_c folder. – Jaap Jansma - CiviCooP Jun 6 '18 at 8:52
  • Thanks for the response. The membership does show up immediately in Find Memberships but not in the register. Can you give me some more details on the permissions of the templates_c folder on Joomla? – cejavila Jun 6 '18 at 13:03
  • I'm having a similar issue with Joomla and Civi, in that changes don't show up until the browser cache is cleared and the page is refreshed. Seems like it's only happening with Joomla sites. Would appreciate if someone could look into this. – LMK Web Oct 11 '18 at 18:40
1

We are having a similar issue, and while this isn't a great answer, the temporary solution has been to install browser add-ons (either in Firefox or Chrome) that clean the cache with one click. On Firefox, I'm using Clear Cache, which also refreshes the page. On Chrome, I'm using Clean Master, and have to manually refresh the page afterwards. Cleaning the Joomla and Civi caches don't seem to make a difference - only the browser cache. Unfortunately, any time we make any changes that we want to see immediately, we have to repeat this process. That includes to discount codes, events, memberships, contributions, etc. It's annoying and hopefully if enough people are also experiencing it and report the problem we can get a permanent resolution.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.