someone of our team managing the events in civiCRM yesterday realized that there are events missing from the the 'manage events' page in our wordpress installation (4.7.31)

in researching i found this Events 'missing' after upgrade to 4.7.19 which very much looked like the issue, but the quick fix of updating CRM/Event/BAO/event.php didn't change anything so i just updated to 5.2.0 as i assumed this should fix it.

unfortunately the events in question are still not shown.

Checking contacts who had been participants in one of these events does show the event listed there and i can get a list of all participants - but i can't manage/edit/duplicate such event.

any hints on how to debug/resolve this?

thanks, markus.

  • i think it's pretty likely permissions are involved - do you have a user with pretty much all permissions on the DB? – user4278 Jun 9 at 23:02

if you have access to your DB you could look in civicrm_event and peruse the data there in case you have some odd values in eg date fields

otherwise try usual of clearing caches, drop templates_c folder etc etc in case the fix has worked but you just aren't seeing it

  • Or search for all events under manage event page. – Pradeep Nayak Jun 7 at 6:36
  • well, searching was one of the obvious things that have been done first - but it doesn't deliver any results, even if using the exact event name. – markusk Jun 7 at 8:33
  • chaches were cleared while updating, so this shouldn't be the issue. the event (i'm limiting my testing to one now even though there might be others) is in the DB with no obvious wonky data - using it's ID in a &q=civicrm%2Fevent%2Fmanage%2Fsettings&reset=1&action=update&id= url i can access and configure it fine. it's - as expected - just not displayed or found in the overviews :( – markusk Jun 7 at 8:38
  • not sure what else to suggest without being able to poke my nose around your system. do new events you create show up fine? – petednz - fuzion Jun 7 at 20:51
  • any chance new Permissions are involved (wild thinking now) – petednz - fuzion Jun 7 at 20:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.