1

After upgrading from 4.7.31 to 5.2.0 the system status page is blank. I made sure the Directory and Resource url settings match; I cleaned up caches and reset paths; I disabled the Asset Cache; no luck. Anything I'm missing?

EDITED TO ADD:

I have since upgraded, and when I go to the status page I get an error that CiviCRM is unable to retrieve an extension. After I update paths, then it just goes to a blank page. The console says: Error: Syntax error, unrecognized expression: #/status

  • Same problem, but simply a 'new' install of 5.1.2. System status was working, now stopped working after installing some pretty usual Drupal modules – Andy Clark Jun 7 '18 at 20:56
  • if your site is a multi-lingual one then may relate to civicrm.stackexchange.com/questions/25232/… – petednz - fuzion Jun 7 '18 at 21:25
  • I had this error when an extension caused a fatal error. Can you look at the logs? In my case it was the sparkpost extension. The latest on github solved my issue – Kevin Cristiano Jun 7 '18 at 22:03
  • Site is Wordpress and not multi-lingual. @KevinCristiano - could you provide a link to the latest on github? – raaboyl Jun 8 '18 at 15:08
  • 1
    github.com/cividesk/com.cividesk.email.sparkpost the changes are in the master branch. And there is not a release. You will have to update manually. – Kevin Cristiano Jun 9 '18 at 10:13
3

Here's one answer that fixed my problem (see my comment above). The cause was that when I created the Drupal system I just used the domain name without the www. But Civi was loaded with www. This is an old problem and I'm a bit ashamed to admit I made this mistake again! But if your system has this mismatch then system status won't work. Fix was to change the base url in Drupal.

  • Am using Wordpress and the base url matches--still blank system status page. – raaboyl Jun 11 '18 at 16:25
1

In addition to cleaning up caches via Administer menu » System Settings » Cleanup Caches and Update Paths, it also pays to delete the templates_c directory.

  • I routinely clean up the caches, especially when upgrading. The problem persists – raaboyl Jul 2 '18 at 21:32
1

Reinstalling Sparkpost extension did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.