2

So I successfully installed CiviCRM and most things are running well but I can't install extensions.

From Gui I get to the "Download and Install button and the installation fails with:

WARNING: The downloader may be unable to download files which require HTTP redirection. This may be a configuration issue with PHP's open_basedir or safe_mode. Unable to extract the extension. Extension Upgrade Failed Download failed - ZIP file is unavailable or malformed

Manual I download and expand the zip file in the extensions directory It shows up as a local install When I click the "Install" button:

the browser shows an address of (myserver)/drupal/index.php?q=civicrm/admin/extensions And the message is: This page isn’t working (myserver) is currently unable to handle this request. HTTP ERROR 500

I suspect some sort of PHP error but I don't know what the solution is.

  • So I've found part of the problem which deals with the manual install. It turns out the error was with one specific extension, the Mailchimp extension. In my server logs i found: "PHP Parse error: syntax error, unexpected '[' in /home/e-smith/files/ibays/drupal/html/sites/default/files/civicrm/custom_ext/uk.co.vedaconsulting.mailchimp-2.0.1/mailchimp.php on line 318" – Stephen Sloan Jun 9 '18 at 19:15
  • Line 318 reads: " $js_safe_object = [ ];" Other extensions install OK using the manual method. – Stephen Sloan Jun 9 '18 at 19:22
  • Per answer below - even though 4.6 still supports php 5.4 there is no expectation that extensions will run on 5.4 – user4278 Jun 9 '18 at 22:53
  • Yes, PHP 5.6 solved the problem. – Stephen Sloan Jun 11 '18 at 18:34
3

The syntax looks fine for me. You will need to check php version you are using. It should be 5.5 or more i believe.

  • Thanks, that was the problem, after updating to PHP 5.6 all is well. – Stephen Sloan Jun 11 '18 at 18:33
  • Wow... Cheers (y) – Pradeep Nayak Jun 11 '18 at 18:34
  • Stephen - great that Pradeep helped you. Etiquette would be for you to 'accept' his answer as that helps guide others reading this – petednz - fuzion Jun 11 '18 at 21:42
2

The main issue is already answered here, but check your php version and configuration against the requirements here: https://docs.civicrm.org/sysadmin/en/latest/requirements/#php

(Also, you might also want to check out 'clean-urls' in Drupal - https://www.drupal.org/docs/7/configuring-clean-urls/enable-clean-urls That's not related to the cause of the problem but makes the URL's in your error message nicer)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.