When i try to run the database upgrade script i get the following message:

Database check failed - the database looks to have been partially upgraded. You may want to reload the database with the backup and try the upgrade process again.

Ive tried a number of times but keep getting the same error message.

2 Answers 2


The upgrade failed the first time for some reason, and all subsequent attempts on the partially upgraded database give this message. Do you have a backup of the original database? Do you know what the original error was?

  • Hi, I have a backup and have restored it, then when i try to upgrade again, i get the same error. Jun 5, 2015 at 2:00
  • Unfortunately it sounds like it was partially upgraded in the past and left in an incomplete state. You may find this page helpful: wiki.civicrm.org/confluence/display/CRMDOC/…
    – Laryn
    Jun 15, 2015 at 19:40

You say, "Ive tried a number of times but keep getting the same error message". It's not clear whether you're reloading the backup in between attempts.

If you are and you're still getting this message, the next step is do delete and recreate the database before reloading the backup. Reloading a backup will replace the values in existing tables - but will NOT delete tables created when updating to 4.6.2, which is a possible cause for your error.

To delete and recreate the database, and assuming the database name is myorg_civicrm...

DROP DATABASE myorg_civicrm;

Then create a blank database with:

CREATE DATABASE myorg_civicrm;

So long as the new blank database shares the same name as the deleted database, your MySQL user will have the same permissions on the new database - so just reload your dumped tables and try again!

  • Hi, thanks for your response. Yes, i am restoring the backup between each attempt. Is there a guide on how to re-create the database? Jun 5, 2015 at 2:02
  • @joycedesign I just edited my answer with details. Jun 5, 2015 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.