2

Getting a 500 error on importing CSV content. Consulted with web host, who found the cause of the 500 Internal Server Error. When I click on the import more than 30 processes is spawned from my account. The limit on my plan is 30 processes and this causes the error as the limit is exceeded. The processes are:

Code: php admin.php

They advised me to contact Civi or check the import settings in order to lower the number of processes spawned simultaneously. You should configure it to wait for the process to complete and then spawn new ones.

How do I do this?

  • It's almost always cheaper & easier to change hosting than to try to get CiviCRM to fit with a cheap hosting plan (which I assume is what you have) - there are a number of CiviCRM providers that provide CiviCRM-optimised hosting - some are pretty cheap – user4278 Jun 21 '18 at 11:22
  • That makes sense in many situations I'm sure. I'm a developer running Civi for my own education on an account with 40+ sites on it, which I won't move for the sake of Civi. I'm looking to make it work with my hosting, which is otherwise very good, rather than buying additional hosting. – dooley Jun 21 '18 at 19:50
3

I found the solution to my issue. The php.ini was causing another issue with my site. When I renamed it, I was able to import as expected.

  • Renaming php.ini doesn't really "fix" anything, though. What it does is prevent the settings in that file from being used by the system, causing it to fall back on defaults or settings set elsewhere in the environment; on someone else's server, this might easily have no effect or make things worse. It would be more helpful to pinpoint a relevant setting like memory_limit, max_execution_time, or max_input_nesting_level to tune. – choster Jun 22 '18 at 22:29
  • Yes, I thought of that, too, choster. For many situations, finding the root cause within the php.ini would be the way to do. In my case, the php.ini was left over from previous hosting and doesn't need to be added with my new hosting. So, I deleted it. Done. – dooley Jun 23 '18 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.