3

I recently noticed that boolean fields (Deceased, Do Not Email, Do Not SMS, etc) are all displayed as "Yes" on contact and membership reports, regardless of their actual values. The data itself is correct and is fine elsewhere, such as in search results and contact displays. The issue seems to be only on report display. The report filters work correctly on those fields, only the display is wrong. I checked my production system, my dev system, and the public demo system at wpmaster.demo.civicrm.org and I see the same thing.

My system is CiviCRM 5.2.2, WordPress 4.9.6, PHP 7.1.16, MySQL 5.7.21.

  • Thanks for reporting this. It sounds like a bug to me. I suggest that you report it on the Issue Tracker. See civicrm.org/bug-reporting – William Mortada Jun 29 '18 at 11:05
  • Will do. One additional detail... I tried the Drupal demo site at CiviHosting and I don't see this issue. Perhaps it's related to WordPress. – Mark Westergaard Jun 30 '18 at 14:26
  • Already fixed! lab.civicrm.org/dev/report/issues/4 – Mark Westergaard Jul 2 '18 at 16:26
  • Fantastic! Would you like to answer your own question in case other people have the same problem? – William Mortada Jul 2 '18 at 16:28
  • Good point! I should have done that instead of commenting. – Mark Westergaard Jul 3 '18 at 17:07
1

Already fixed! See: CiviReports issue with boolean fields

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.