2

I thought I had a fix, but I'm still getting a 500 error on importing a batch of 16 organizations. Host tells me CiviCRM is spawning more than 30 processes, which is the host's limit.

Trying to get Civi to work on my current host. It's a shared server with a decent host with their top tier plan. Moving everything for Civi isn't an option I'll consider since I have 40+ dev and low traffic sites set up on the account that are all working well within plan limits. I installed Civi there for my education. So if I have to buy Civi-specific hosting, I'd prefer to poke around first.

Any ideas how I can limit the number of processes Civi spawns on import?

2

I don't know of any way to limit the processes. Importing is a large task since it's hitting so many fields, tables, etc. That means a lot of processes regardless of how many records you're importing. Shared servers often times have too low of limits to be able to fully use CiviCRM without running into issues. It's why we finally ended up just getting our own server, setting it up so that its minimums would still be more than enough for Civi, and then using it for all our sites.

2

CiviCRM isn't spawning processes directly, that's probably apache, or your web server. When using the web interface to do CiviCRM imports, and many other activities, CiviCRM uses some clever techniques to avoid things timing out, but that have other trade-offs in server requirements. This is probably not the only place where you might run into trouble.

FWIW, 30 processes should be adequate, I suspect the server is not setup optimally.

If you have the ability to import a csv file into a temporary table in your database first, there's also an option to do the import from a table, that might generate fewer processes.

1

A workaround would be to clone your website to your localhost development environment, do the import there, then replace the live database with the one from localhost. If you need to retain the live URL throughout this process, you can point it to localhost by editing your hosts file.

[Aside: this is a good way to do CiviCRM upgrades too, since it is far easier to roll back and repeat if anything goes wrong]

  • I'm working on this. I've been using XAMPP on Windows 10 for my WordPress installs. I've been unsuccessful in getting either two versions of PHP to work in one install of XAMPP or getting two XAMPP installs to work together. This may be the time to change my local dev environment to something like Docker or VVV. – dooley Jun 27 '18 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.