0

wordpress 4.9.6 Clickatell 4.1 All was working fine until upgrade to Civi 5.22 and upgrade to SMS API 1.5 (yup in retrospect should have tested separately!)

phone is home-mobile-primary

2

Looks like sites/all/modules/civicrm/CRM/Activity/BAO/Activity.php is failing in function function sendSMSMessage( because $doNotSms = TRUE; on line 3154. Set it to false and you should be Ok. However, the check will not happen, so all numbers (even Do Not SMS #s) will get the SMS.

The other option is to comment out the following block and add an if block: /* if ($smsProviderParams['To']) { // If phone number is specified use it $toPhoneNumber = trim($smsProviderParams['To']); Civi::log()->debug(print_r($smsProviderParams, true)."\ntoID: $toID\n"); //echo "<pre>".print_r($smsProviderParams, true)."</pre>"; $doNotSms = FALSE; } elseif ($toID) { */ if ($toID) { // No phone number specified, so find a suitable one for the contact

  • Brilliant - option 1 worked a treat. Thanks so much! FYI in wordpress it's line 1820 – LesleyJill Jun 27 '18 at 12:53
1

Have raised this as an issue with the extension maintainers:

https://github.com/veda-consulting/org.civicrm.sms.clickatell/issues/20

0

This is a Civi core bug. It happens with Twilio too: I tested in Civi 5.4.0 .

Seamus Lee has filed an issue against Civi core and submitted a fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.