0

I can not send the mailing, in the report this message: "Delivery has not yet begun for this mailing. If the scheduled delivery date and time is past, ask the system administrator or technical support contact for your site to verify that the automated mailer task ('cron job') is running - and how frequently." what am I doing wrong? What should I correct? Thank you And if the problem is geolocation? And if the problem was the google API? I also had difficulty understanding OpenStreetMaps, maybe I was wrong with them? Is anyone practical with OpenStreetmap? Thanks In setting mapping I put this indicated in the screenshot: enter image description here

enter image description here

  • I think this can happen when your 'user' timezone and your server or site timezone are out of kilter – petednz - fuzion Jul 1 '18 at 20:12
  • I found this article: can it be useful for the problem? blog.wikimedia.org/2018/06/05/improved-geocoding-in-civicrm – simonetta officinecollegate Jul 2 '18 at 8:06
  • where to set the time zone? Thanks – simonetta officinecollegate Jul 2 '18 at 9:18
  • your problem has nothing to do with geocoding if i understand your question. i think i misunderstood your question first time and i expect it has nothing to do with timezone. do you have the Scheduled Job set to run - and is your cron running? – petednz - fuzion Jul 2 '18 at 11:25
  • a message arrives on my email once a day which says that the cron is ok : --2018-07-03 00:00:02-- crm.teatronecessariogenova.org/wp-content/plugins/civicrm/… Resolving crm.teatronecessariogenova.org (crm.teatronecessariogenova.org)... 178.63.119.153 Connecting to crm.teatronecessariogenova.org (crm.teatronecessariogenova.org)|178.63.119.153|:443... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [text/html] Saving to: ‘-q’ 0K 14.3M=0s 2018-07-03 00:00:02 (14.3 MB/s) - ‘-q’ saved [145] – simonetta officinecollegate Jul 3 '18 at 12:23
1

If your cron is not running then there is nothing to 'tell' the Scheduled Jobs (which starts the mailing job) to run.

As a quick fix you should be able to go to your Scheduled Jobs (Admin > System > Scheduled Jobs, or /civicrm/admin/job?reset=1 in Drupal), find the Mailings scheduler job and use 'Execute Now' under the 'More' option - this should cause any overdue Mailings to be sent out.

To set up a cron so that the Jobs run automatically you need to follow the instructions here: https://docs.civicrm.org/sysadmin/en/latest/setup/jobs/

You also need to set any relevant Scheduled Jobs to be 'enabled' (under More)

  • thank Petednz, yes, I have already done this manual operation (Admin> System> Scheduled Jobs, find the Mailings planning job and use 'Run Now' under the 'Other' option) but this is a manuale sistem, I have already set all following the guide : docs.civicrm.org/sysadmin/en/latest/setup/jobs – simonetta officinecollegate Jul 8 '18 at 5:24
  • I have problems sending for mailings, the message is: "Delivery has not yet begun for this mailing. If the scheduled delivery date and time is past, ask the system administrator or technical support contact for your site to verify that the automated mailer task ('cron job') is running - and how frequently." – simonetta officinecollegate Jul 8 '18 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.