3

Any suggestions how to get the civicrm installer to recognize that I have permission to create triggers. The installer says I don't, but my host says I do. I can create triggers with phpMyAdmin. I am using MySQL - it is a new site, but I don't know the version number. I have asked. Will enter it when I know.

Here I am substituting the word username for my real username. I logged into WordPress with user: username, and logged into phpMyAdmin with user: username I ran the query you suggested and got: Your SQL query has been executed successfully. SHOW GRANTS FOR 'username'@'localhost' GRANT USAGE ON . TO 'username'@'localhost' IDENTIFIED... GRANT ALL PRIVILEGES ON username_site.* TO 'username'@'loc...
GRANT ALL PRIVILEGES ON username_civi.* TO 'username'@'loc...

  • 1) Please confirm you're logged into phpMyAdmin as the same user as the CMS user and 2) please edit your question with the results of the following SQL: SHOW GRANTS FOR 'username'@'localhost', substituting your own MySQL username (and the hostname if need be) – Jon G - Megaphone Tech Jul 6 '18 at 23:44
  • Oh - and also please post the database software (MySQL/MariaDB/Percona/etc.) you're using along with the version? – Jon G - Megaphone Tech Jul 6 '18 at 23:44
  • When you say The installer says I don't, it can help to share the specific wording of the error message. This makes it easier for helpers to know what you're seeing. – Chris Burgess Jul 8 '18 at 20:03
1

I found getting SUPER privileges by the host was necessary. After that the warning about Triggers disappeared.

  • 1
    I'm glad that worked, but that should not be necessary unless you're running a very old version of MySQL. The need for SUPER privilege went away with MySQL 5.5. – Jon G - Megaphone Tech Jul 7 '18 at 22:56
  • same worked for me even though I think I have a reasonably current mysql version (mysql Ver 15.1 Distrib 10.2.21-MariaDB, for debian-linux-gnu (x86_64)). I had changed and updated some packages on my vServer which broke the triggers until I granted SUPER privilege – sleidig Feb 8 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.