3

upon upgrade from 4.7.31 to 5.3 the site could not load any civi pages, it would give a generic error message.

in the log I see:

Civi\Payment\Exception\PaymentProcessorException: CRM_Core_Payment_PayPalImpl: Payment processor type is not defined! in CRM_Core_Payment_PayPalImpl->__construct() (line 73 of /var/www/xxxxxx/sites/all/modules/civicrm/CRM/Core/Payment/PayPalImpl.php).

but this site does not use paypal, it uses authorizenet so I have no idea why this is causing a fatal error

my temp workaround was to just comment out line 73 of PayPalImpl.php but I'll need to verify that payments still work. Anyone else have a similar issue with 5.3?

  • I've confirmed that authorizenet payments work fine with this line commented out; I'll see if I can dig deeper into this bug later, please post a comment if you've hit this same issue so I know if this is a real bug or just my server – ericG Jul 9 '18 at 19:53
  • Please create an issue for this on lab.civicrm.org/dev/core/issues – Aidan Jul 10 '18 at 9:37
  • @ericG I would be checking to see what is going on in the isPayPalType function as that is returning FALSE which is causing the error to be thrown as per github.com/civicrm/civicrm-core/commit/… – Seamus Lee Jul 10 '18 at 9:44
  • what rows do you have in civicrm_payment_processor table? – user4278 Jul 10 '18 at 13:02
  • At a guess, I would say that you have probably got some paypal contributions but don't have a paypal processor configured? – Matthew Wire Jul 10 '18 at 14:27
1

I posted this to gitlab here https://lab.civicrm.org/dev/core/issues/250 and the issue turned out to be related to odd records in my database.

this query, from Elieen exposed the bad row

SELECT p.id, p.name, p.class_name, p.is_active, pt.id, pt.class_name, pt.name
FROM civicrm_payment_processor p
LEFT JOIN civicrm_payment_processor_type pt ON pt.id = p.payment_processor_type_id
+----+--------------------+----------------------+-----------+------+----------------------+---------+
| id | name               | class_name           | is_active | id   | class_name           | name    |
+----+--------------------+----------------------+-----------+------+----------------------+---------+
|  1 | Dummy Processor    | Payment_PayPalImpl   |         1 |   10 | Payment_Dummy        | Dummy   |
|  2 | Dummy Processor    | Payment_Dummy        |         1 |   10 | Payment_Dummy        | Dummy   |

so I updated the row in civicrm_payment_processor to change Payment_PayPalImpl to Payment_Dummy and everything works without the modification to civi code.

0

I have had the same message after updating from 5.2.1 to 5.3.2. I have 2 sites, neither have any contributions configured, either thru paypal or anyone else. Both sites were upgraded. The other is working fine but this one cannot get into civi from drupal entry.

Civi\Payment\Exception\PaymentProcessorException: CRM_Core_Payment_PayPalImpl: Payment processor type is not defined! in CRM_Core_Payment_PayPalImpl->__construct() (line 73 of /mysite/public_html/drupal/sites/all/modules/civicrm/CRM/Core/Payment/PayPalImpl.php).

I took the advice of editing out line 73 and all is good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.