1

I'm running WP 4.9.7 Multisites, CiviCRM 5.3

I've created a profile with the information I want to gather from people. I've enabled the option to create a Wordpress user.

I go to the contribution page containing the profile, and it shows me all the appropriate fields to create a new WP user, as well as all the other profile fields.

I go through the process, and it all seems to work. It inserts an entry in CiviCRM. But it doesn't create the Wordpress user... Not even a pending user.

Have I missed something somewhere?

Thanks

  • I'm assuming that this lack of creating a Wordpress user is related to why I'm not getting an email to confirm my Wordpress membership... I'm not adding any people to groups though. Should I be? At this point I'm not sure that groups are much use, but maybe I'm wrong... – Norman Cates Jul 14 '18 at 10:32
  • When your contribution page appears to the public, can you confirm that the email address, username, and Password boxes appear in addition to the Profile fields that you've set up. Also, do you have the box "Membership Section Enabled" ticked in the Contribution Form set up? – peterb Jul 20 '18 at 22:27
0

Follow the steps as described here

You may have missed the below step -

For WordPress you will also need to check the box "Anyone can register" in the WordPress general settings.

  • Thanks but that setting is enabled. I can register in Wordpress using the standard methods. – Norman Cates Jul 14 '18 at 11:04
0

It might sound obvious, but I'll admit getting caught by this on one occasion because I didn't test as an anonymous user!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.