1

I want to use the most stable version with the most extensions as possible, with Drupal, 7 is still better than 8 for most projects.

Is it the same with civi?

I already installed and configured 5.x can I downgrade to 4.x ?

1

Many extensions will work with both 4.6.x and 5.x while some only work with one. Some extension authors are dropping support for 4.6. For example, in the recent security release announcement, the extended reports extension was available for 4.6 but is now only supported on current 5.x

The proponents of 4.6 and LTS emphasise stability.

If you want features and extensions then 5.x is the better choice.

You can upgrade from 4.6 to 5 but there is no supported downgrade process.

FYI (you didn't quite ask this!) - CiviCRM on Drupal 8 is moving rapidly but D7 is much better supported at this point.

2

Support for CiviCRM 4.6 is nearly at an end. It is slated to end at the end of this year.

5.x is the supported stable release. 4.6 is pretty much a security only branch now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.