It tries to go to "http://mycivicrmsite/civicrm/a" but it giving an "Unknown path" error. It doesn't seem to redirect to "http://mycivicrmsite/civicrm/a#/mailing/new" which seems to work.

We don't have any extensions installed.

  • 1
    After changing line 56 in file civicrm/CRM/Mailing/Controller/Send.php from CRM_Utils_System::redirect(CRM_Utils_System::url('civicrm/a/', NULL, TRUE, '/mailing/new')); to CRM_Utils_System::redirect(CRM_Utils_System::url('civicrm/a', NULL, TRUE, '/mailing/new')); it now works. The last '/' in the first parameter 'civicrm/a/' was causing the error. Is this a bug or is there a configuration issue in our instance?
    – JCN
    May 21, 2015 at 17:59
  • I'm having the same issue, but neither of the above solutions seem to work for me. Server config problem? I can't think what might be breaking the URL at the hash(#). Sep 14, 2015 at 1:00

5 Answers 5


I resolved the issue. Apparently there is a conflict with the Deslash option in Drupal module Global Redirect 7.x-1.5. After unchecking the Deslash option, restarting the browser and clicking the New Mailing menu item, it works.

Please beware if you've installed module Global Redirect 7.x-1.5. The Deslash option is enabled as a default.

Just a thought... Although there is no need to change 'civicrm/a/' to 'civicrm/a' in source file civicrm/CRM/Mailing/Controller/Send.php, should it be changed anyway? After looking at other CRM_Utils_System::url() calls in the module, I see that many other calls do not have '/' as the last character for parameter $path. But it seems the parameter $path has been set to 'civicrm/a/' in civicrm/CRM/Mailing/Controller/Send.php for quite a while.


Safari on the MAC seems to get this error regardless of the Global Redirect Fix (which doesn't appear to work).

Using 4.6.3 Removing the trailing slash lines 56, 62, 65 and 71 of civicrm/CRM/Mailing/Controller/Send.php make this work for me on safari/mac. Someone also reported that it doesn't work on some versions of IE.

  • I am having same issue Civi 4.6.11 on safari on Mac os x. However on chrome seems to be working fine..
    – Tapash
    Jan 21, 2016 at 11:06

I'm having the same issue for the first time but, a year later than the folks above - I'm providing this info as further clarification of the issue with Safari Browser and this redirect inside CiviMail

Our site is at Drupal 7.52/Civi 4.7.13 and another site with same issue is at Drupal 7.50 and I'm not positive which civi version

"unknown path" error when trying to access New Mailing Only seems to occur with Safari on a mac (and on an iPhone)

Further clues: The url box at the top of the browser very quickly cycles through the following three urls when I choose "New Mailing"

1) my_domain.com/civicrm/mailing/send?reset=1
2) my_domain.com/civicrm/a/#/mailing/new
3) my_domain.com/civicrm/a

On other browsers, the url's cycle through just the first two of these, and don't reach the third which is the thing that causes the "unknown path" error. This is happening on at least a couple of sites as I note above, and doesn't seem to be directly associated with Drupal or CiviCRM updates.

Perhaps there has been an update to Safari that's reawakening an error from a year ago? I'm on Safari Version 10.0.1 (11602. I don't know how to tell when it was updated..

Per above, I tried changing 'civicrm/a/' to 'civicrm/a' in lines 53,59,62,68 of my ...sites/all/modules/civicrm/CRM/Mailing/Controller/Send.php file and it didn't change the error.

  • Thanks for your post Rick. You have posted this as answer but this doesn't appear to answer the original question. You are unlikely to get a response here so you would be better off posting this as a new question. Include a link back to this question explaining why the answers don't work for you. Dec 11, 2016 at 10:45

I just had this same issue using Safari 11.03 on MacOS 10.13.3

It transpired that when I turned off AVG antivirus's "Web Shield" all was well.


Four years after, still Safari + CiviMailing doesn't cope well ! I still have this issue. All right let's use FireFox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.