The documentation says:

After people subscribe to mailing list groups—via the subscribe link or a profile—CiviCRM will automatically send them an email asking them to confirm their subscription. Until they click the confirmation link in the email, their contact information will appear in CiviCRM with their group subscription set to Pending. When they confirm, CiviCRM will automatically change their group subscription status to Added and they will be sent a welcome message. (Note: When users subscribe to multiple groups at once, a confirmation email is sent for each group separately.)

I cannot get this to work. Civimail works fine. Send mail to individuals or to a list that resulted from a search works fine.

People join a group through a profile. The advanced settings in the profile has the group name ("Volunteers") and a return ddress but no emails are sent.

I have checked to see if there is a scheduled job that handles this but could not find one that seemed relevant.

  • I've also tried adding a groups field to the profile but that had no effect.
    – Vietyank
    May 22, 2015 at 0:16
  • Is it working via the Subscribe page but not via Profile - or neither. Also i thought there was a setting where you could disable confirmation. Can't spot it in the UI - might be in civicrm.settings.php but not about to go digging to check
    – petednz - fuzion
    May 22, 2015 at 0:27
  • I wan unable to find a setting to disable confirmations in civicrm.settings.php and if there is one in the UI somewhere, I was unable to find that too. When I go to www.letsbanfracking.org/civicrm/mailing/subscribe, I get a 404 error, even when logged in as a super-user.
    – Vietyank
    May 22, 2015 at 1:00
  • The link to the subscribe page is letsbanfracking.org/civ/mail-list-subscribe. Not as documented. We are receiving notifications when using that link but not with using the profile.
    – Vietyank
    May 22, 2015 at 3:23

1 Answer 1


Check your settings in Administer > CiviMail > CiviMail Component Settings:

CiviMail Settings

  • heh - great - don't recall when the option was added so double opt-in for the profile was separate but seems to be the answer Dennis needs.
    – petednz - fuzion
    May 22, 2015 at 20:26
  • No problem at all!
    – Laryn
    May 23, 2015 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.