1

Inside /sites/all/modules/civicrm/CRM/Core/Resources.php Line 738 and for civicrm version 5.3.1

 $editor = Civi::settings()->get('editor_id');
    if ($editor == "CKEditor") {
      CRM_Admin_Page_CKEditorConfig::setConfigDefault();
      $items[] = array(
        'config' => array(
          'wysisygScriptLocation' => Civi::paths()->getUrl("[civicrm.root]/js/wysiwyg/crm.ckeditor.js"),
          'CKEditorCustomConfig' => CRM_Admin_Page_CKEditorConfig::getConfigUrl(),
        ),
      );
    }

I get error event configuration page which is as follows: Failed to load resource: net::ERR_NAME_NOT_RESOLVED and url which is not loaded is as shown below https://newspace/prestige/public_html/sites/all/modules/civicrm/js/wysiwyg/crm.ckeditor.js So link is incorrect which seems to be due to incorrect [civicrm.root],

Can I set $civicrm_root in civicrm.settings.php and can that help fix it? When I place directly the url it works but it is in the code below which is Core part of civicrm

3

You can write the below code in civicrm.settings.php file to override the current value of [civicrm.root] token.

global $civicrm_paths;
$civicrm_paths['civicrm.root'] = array(
  'url' => 'https://website_url.com/.../civicrm',
  'path' => '/path/to/civicrm/folder/',
);

Similarly, it can be used to set [civicrm.files] and [cms.root].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.