3

I use CiviMail in conjunction with a catch-all mailbox. The bounce processing updates the database when there’s bad email addresses and reports bounces on the mail report. It also handles user opt-outs. We use DreamHost, and they’re dropping support for catch-all mailboxes as of 10/1/18. Ugh. DreamHost doesn’t support VERP either. I found this documentation: https://docs.civicrm.org/sysadmin/en/latest/setup/civimail/inbound/ which has this section:

Variable Envelope Return Path (VERP) CiviCRM Bounce handling depends on using Variable Envelope Return Path (VERP). If your email server doesn't support VERP you will only be able to properly support bounce requests if you can set up a catch all email. If you cannot setup a catch all email and your server does not support VERP you will need to edit packages/Mail/smtp.php as follows near line 275: //if (!empty($headers['Return-Path'])) { // $from = $headers['Return-Path']; //}

So, I set up a new mailbox [email protected] and marked it in Administer | CiviMail | Mail Accounts as the account for bounce processing. I commented out the three lines of code shown above. I did a test mailing with a bad email address, but the delivery failure went back to the sending email address ([email protected]) instead of [email protected]. What am I doing wrong??? Thanks for your help!

UPDATE: I don't want my email blasts to come from [email protected]. CiviMail lets you specify the bounce email address in Administer | CiviMail | Mail Accounts. It just doesn't work! One clue I found was in my own question posted in 2015 (Problem using CiviMail with Bluehost), where Xavier points out that the lines of code I commented out are the one's needed to be able to identify who was the recipient, so if it bounces, Civi can identify it properly. So, I reinstated those lines of code. But the bounce went to the old Catch-All account, instead of the new bounce account. Then I disabled the Catch-All account. Now I can't find the delivery failure email anywhere?!? Please help!!! I'm using CiviCRM 4.7.20 and the current version of WordPress.

4
  • I think in the case you're describing you'd have to use [email protected] as the FROM address in your mailings as well.
    – Demerit
    Jul 29, 2018 at 19:29
  • 1
    Responding to your edit, I don't think it's correct what you're saying about Administer | CiviMail | Mail Accounts. What that does is tell civi where to retrieve bounces from so that it can process them. If the issue is with having the word "bounce" appear to recipients, then set up one called e.g. "[email protected]", and use that as the FROM, and then with the lines commented out that is where bounces will go.
    – Demerit
    Jul 30, 2018 at 18:17
  • Thanks Demerit. This appears to work, though I don't like it. I have multiple FROM addresses and Civi only allows 1 bounce address. For another thing, people sometimes reply to our [email protected] address, and the bounce process sticks those messages into the CiviMail.Ignored folder. That's a quibble, I suppose. Question: On the Mail Account screen there's a Return-Path field. Can I do something with that? I tried putting [email protected] in there, (with the lines reinstated), but it didn't seem to work. Thanks...
    – jimcrist
    Jul 30, 2018 at 19:33
  • 1
    I don't know what that particular return-path field does. Humorously the documentation only says "You can leave the return path empty" (docs.civicrm.org/sysadmin/en/latest/setup/civimail/…). I'm guessing it's left over from some older version - would have to check the code to find out. If you're ok with using something like "[email protected]", you could create and use that address and use verp.
    – Demerit
    Jul 30, 2018 at 21:09

1 Answer 1

0

Demerit's comments probably constitute the best answer available. It's a loss in flexibility and functionality compared to being able to use a catch-all mailbox, but it's probably as good as it gets, given the situation. I may experiment with SendGrid, but I'm not impressed with them so far. It's a public company that makes it difficult to ask a question. I could only ask a question after I signed up with them. It was answered by someone who just googled SendGrid CiviCRM and came up with a few fairly worthless links.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.