The latest stable release of the MailChimp extension for CiviCRM isn't installing on our Civi 5.3.2 via the Civi internal extension installer. Admin interface displays

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: unknown error

PHP error log shows no related errors. Also getting the following when coming back to the Civi admin interface after checking the log:

Civi alert messages

UDATE: On my fifth or sixth attempt to install, it finally worked. Didn't change anything prior to this. No idea why.

  • 1
    Any extension marked as compatible with 4.7 should also be compatible with CiviCRM 5.0+. It might be worth editing your question to indicate what the error message/log entries are when you try to install Mailchimp on 5.3.2. Jul 31, 2018 at 15:53
  • 1
    Also - I was able to successfully install Mailchimp on both 5.3.2 and 5.5alpha. Jul 31, 2018 at 15:55

1 Answer 1


Crazy as it sounds, this is one case in which it may be advisable to repeat the same behavior and expect different results. There's no clear or obvious reason why the installer failed repeatedly, but on the fifth or sixth attempt, it finally worked. Memory glitch on the remote server? Hiccup in the CPU? Who knows. But if you encounter the same issue, try and try again, and hopefully you'll get the desired outcome sooner or later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.