0

I've recently wanted to add the time to my import of external (non-Civi) transactions. Before this, I just imported the date, which is OK, but the data is there, so why not import it?

I keep getting an "Invalid value for field: Receive Date" error when I try to run the import. Here's the value returned in the Import Error file:

Receive Date: 07/28/18 02:34 AM

I know I select the proper date format mm/dd/yy for the first step of my import. I can't figure out what the problem is.

Receive Date is a datetime in SQL in case that might be relevant. Civi 5.2.1

  • sometimes you can get a clue as to what is required by doing an export of some data including that field just to see the format it gives you – petednz - fuzion Aug 2 '18 at 3:40
  • have you tried it without the time component? – petednz - fuzion Aug 2 '18 at 3:40
  • It imports fine without the time component. Good thought to look at an export; the format there is yyyy-mm-dd hh:mm:ss (no am/pm). I tried an import with that format, and received no error (which is an improvement), but the time data was not imported, only the date (time set to 00:00:00 default). – Phil Morice Brubaker Aug 2 '18 at 14:45
  • you could see if our csvimporter works any better than the core tools - github.com/eileenmcnaughton/nz.co.fuzion.csvimport – petednz - fuzion Aug 2 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.