2

I'm just getting started with CiviCRM and trying to install on our WordPress site.

I completed the initial install once, but accidentally used the existing WordPress database - I would prefer to install on separate database.

So I have deleted the plugin, via WPadmin. Removed CiviCRM tables from the database using the drop sql file. Uploaded the CiviCRM files to server again and tried to activate the plugin.

The plugin is activated, but clicking the CiviCRM button in the lhs menu gives me error message below. Seems like CiviCRM is looking to the old install in the WordPress database?

How to correct this please and reinstall in separate db?

Initialization Error

Array
(
    [callback] => Array
        (
            [0] => CRM_Core_Error
            [1] => simpleHandler
        )

    [code] => -18
    [message] => DB Error: no such table
    [mode] => 16
    [debug_info] => SELECT id, name, value, domain_id, contact_id, is_domain, component_id, created_date, created_id
FROM civicrm_setting
WHERE (domain_id = 1) AND (is_domain = 1)
 [nativecode=1146 ** Table 'huWP_db.civicrm_setting' doesn't exist]
1

If you planning to reinstall CiviCRM on separate database than you will need to delete the civicrm.settings.php file which holds all the db settings.

Since you are using wordpress you can locate the file in one of the place below

wp-content/plugins/civicrm/civicrm.settings.php

or

wp-content/uploads/civicrm/civicrm.settings.php

HTH

Pradeep

  • thank you Pradeep. I have found the setting file in the uploads folder. All good now:) – dgk112 Aug 2 '18 at 15:14
  • Cool. Can you mark this as Answered so that it will be useful for others? – Pradeep Nayak Aug 2 '18 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.