I have civicrm on a local server using Drupal7. I have had the same issue with every recent upgrade.
The SysAdmin manual contains the following url to update the database following an upgrade: http://example.org/civicrm/upgrade?reset=1

In my case I am using a local fileserver so this becomes: http://myserver/drupal/civicrm/upgrade?reset=1 This has not worked for me on a number of upgrades which resulted in me finding a different method by mistake. (honesty). The url I have now used successfully is : http://myserver/drupal/index.php?q=civicrm/upgrade?reset=1

suggesting the following generic url http://example.org/index.php?q=civicrm/upgrade?reset=1

So my question is whether there is an error in my original install which is causing the documented url not to work?

1 Answer 1


Your local server probably isn't configured in a way to allow for "clean urls". See https://www.drupal.org/docs/7/configuring-clean-urls/enable-clean-urls

  • Clean URLs are not enabled so thanks for pointing out the problem. Commented Aug 4, 2018 at 21:08
  • You'll find most examples assume Clean URLs is enabled. They are though just a simpler representation of the format you posted above.
    – Aidan
    Commented Aug 6, 2018 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.