4

Can I assume that the fix mentioned in this post is for 4.6.4 NOT 4.6.3, the current stable version?

http://forum.civicrm.org/index.php/topic,36339.msg154556.html#msg154556

Any idea how long until 4.6.4 is the stable version or what magic happens in that version to allow Wordpress to use the title of the PCP for the page title (instead of the site title)?

3

On reviewing the situation in the presence of various plugins that try and change the title for SEO or Open Graph reasons, I think there is an issue with the way Civi tries to set the title. I've created at pull request on the CiviCRM WordPress plugin's repo at GitHub that should fix this.

2

The forum post indicates that it was already fixed in the 4.6.0 version of civicrm. Please read the forum topic closely, specifically haystack's and coleman's reply here:

http://forum.civicrm.org/index.php/topic,36339.msg154574.html#msg154574

If you need to backport a patch to your existing version, this document will be of help:

http://wiki.civicrm.org/confluence/display/CRMDOC/Verify+a+bug+fix

  • I guess I have a bigger issue then. My site which is 4.6.3 does not show page titles when viewing pages thru Civi URL (as opposed to a shortcode in a WP page). I did test it in the Twenty Thirteen theme that is used on the demo site and no dice. I poked around other settings in WordPress (permalinks, uninstalled plugins) but haven't been able to get them working. Any ideas how else I can test and get this working. – RayWright May 22 '15 at 16:57
  • can you try and test the same thing on the demo server and see if it actually does the right thing (as the forum topic suggests). Would be good to confirm that – Donald Lobo May 22 '15 at 17:12
  • The Wordpress Demo, which is 4.6.4 works fine - I tried a PCP, Conribution and an event - all display the page title properly. – RayWright May 22 '15 at 17:22
  • I would try disabling all non-civi related WP plugins and see if that helps on your site. Also do all your testing / experiments with the 2013 theme – Donald Lobo May 22 '15 at 19:20
  • Started there, I'm all too familiar with a plug-in breaking something! I've removed all my custom templates, custom php functions, even styling (yes, I know that shouldn't have anything to do with it but since I was testing). Still no dice. I am going to try a fresh install of 4.6.3 to see what that gets me. (I was in WP 4.2.2 so maybe that's the problem, I'll try both 4.1.2 and see where I land....) – RayWright May 22 '15 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.