CiviCRM 5.3.1 with Omnipay extension 2.5

Added a PaymentExpress PxPay processor. After setting up a recur contribution for a contact the first payment is done successfully without any errors.

The second payment run by the scheduled job ProcessRecurring only records a pending payment for the contact. The job log at civicrm/admin/joblog?jid=18&reset=1 shows only the starting of the execution message. There is no Finished indication of the job so it seems it errored in between and aborted the execution.

enter image description here

There is a success message in the ConfigAndLog file at the same time when the above job was started at 00:41:45-

Aug 10 00:41:46  [info] Contribution record updated successfully

Aug 10 00:41:46  [info] Success: Database updated

But, when I check the log tables, the contribution was never set to completed.

  1. If I execute the job manually the recur payment is completed successfully.
  2. If I manually run the completetransation API from the API explorer, it correctly completes the payment.

So there seems to be no way I can replicate this behaviour from my side. It is just that the automatic cron job fails to give the proper result. Shrug.

No error reporting in the system log table -

295 payment_notification processor_id=11 {"q":"civicrm/payment/ipn/761/11","result":"00001100039341640bfef9f4cb5d3c06","userid":"****","IDS_request_uri":"/civicrm/payment/ipn/761/11?result=00001100039341640bfef9f4cb5d3c06&userid=****","IDS_user_agent":"***"}

Can anyone point out what is wrong happening here?

UPDATE: There is no system log entry for the recur payment. It seems the return URL is not triggered when the job is executed.

  • When you run the completetransaction API call, you're probably logged in as your own user with presumably some level of admin rights. When cron executes it, this may be using a different user account. Could this be explained by different permissions for the calling user? – Chris Burgess Aug 11 at 6:50
  • Also a note that above you say Paypal PxPay, but AFAIK you'll be talking about PaymentExpress PxPay? – Chris Burgess Aug 11 at 6:51
  • Ah yes, a bit typo there - updated the question. On further debug - I see it is a problem related to the redirect. When I execute the job manually it redirects me to the payment site and gives an approved status. Auto execution isn't able to handle the redirection and finally doesn't complete the payment on either side. – jitendra - fuzion Aug 11 at 14:21
up vote 1 down vote accepted

We contacted the payment express and asked them to setup the PxPost creds for the client and then the recur started to work properly. Seems it is a necessary config for recur to function correctly using the automatic cron execution. Below lines is from Rishabh(Payment Express team member)

The PxPay 2.0 is only used to tokenized the card details and PxPost runs in the backend to rebill those tokens in automatic process.

You will not be able to rebill the tokens automatically, until you have PxPost setup in the backend.

Thanks :-)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.