Currently on:

  • CiviCRM - 5.3.1
  • Mosaico - 2.0-beta3.1512698300
  • CiviCRM Bootstrap theme - 0.1-alpha14
  • Flexmailer - 0.2-alpha5

In Firefox 'Quantum' - when hitting Continue on a mailing created this morning civicrm/a#/mailing/59 (with another browser) -> it's stuck "Loading" (see top right) when I hit Edit on the Mosaico Mailing

enter image description here

3 Answers 3


The current version produces a "Update your browser!" message - which is not helpful since I already have the latest, and that is not the problem.

Mosaico itself (not just the CiviCRM integration) is picky about the plugins you have installed in your browser.

See https://github.com/voidlabs/mosaico/issues/383#issuecomment-428911320 and https://github.com/voidlabs/mosaico/issues/312#issuecomment-295278878

You have the RightToClick extension installed and this extension manipulates HTML content. Doing so it would break the email template generation. That's why we give that alert.

Any extension that alters html for every iframe in the page is an incompatible extension: AFAIK apart RTC extension, the only other extensions doing that are spam stuff.

So paraphrasing, if they don't like the look of your plugins you are blocked.

Go through your plugins and disable them until you find which one is causing the problem.

In my case, it was the Google Analytics Opt-out Add-on - disable that and it passes the compatibility test.


In Chrome -> all is well: for the exact same url: civicrm/a#/mailing/59 - I get passed the "Loading" -> to a fully loaded Mosaico screen:

enter image description here

  • Did you try to clear the civicrm cache? This could also be caused by the asset caching, not sure how to clear that cache. Commented Aug 14, 2018 at 8:53
  • Same URL different browser though; you can disable assett caching in rhe Administer debug settings page and after that run clean CiviCRM caches that’s how they clear out - but that does not fix this. I’ve had other issues with Angular forms (mailing one) with clients using that on iPad (Safari). Commented Aug 14, 2018 at 10:28
  • That all sounds to me something wrong with the assets. Maybe try to see what error comes up when your press f12 in firefox (you get the developer part of the browser). You can then see whether javascript gives an error or somesort of document gives a 404 not found http error. Commented Aug 14, 2018 at 11:16

I had this issue emerge recently with Safari 14.1. Based on the above advice, the fix was to disable the Wayback Machine extension I had recently installed in Safari.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.