5

I'm using Joomla 3.4.1 with CiviCRM 4.6.3 on a demo site as part of a re-design. I've used the CiviCRM profiles html snippet to create a Joomla signup module. See here for example.

It worked once - storing the name and email into CiviCRM and even re-directing to the proper page and giving a thank you message after it stored the data.

However, now when you hit "save" in the module, this time nothing is saved and it kicks you back to the front page. I've read the manual, searched the forums, and tried a bunch of stuff, but nothing works. What am I missing?

  • 1
    Have you tested by submitting just the profile in either create or edit mode? Does that work? – petednz - fuzion May 22 '15 at 23:08
  • 1
    Yes. Works in Use Profile Create mode. But that takes you to it's own page, doesn't use as module. – Devin May 22 '15 at 23:30
  • 1
    Have u checked the civicrm error log and see if any errors are recorded when you do the above – Donald Lobo May 23 '15 at 2:10
  • 1
    Nothing in the log. And the snippet into a 'page' doesn't work. – Devin May 23 '15 at 17:37
  • 1
    is this the path to the base profile, or something you or joomla cook up? tremololabs.com/clients/IREHRTEST/… and if it is, does it work as expected? – petednz - fuzion May 26 '15 at 4:15
1

I wonder if it's the recaptcha on the form action page?

http://tremololabs.com/clients/IREHRTEST/index.php?option=com_civicrm&task=civicrm/profile/create&gid=15&reset=1

My guess is that posting to that page without the recaptcha data (which is what your form does) is going to cause the server to be annoyed, and perhaps there's some kind of code or server security something that is hiding the response and just sending the user to the front page of your site? Do you have some kind of special configuration for your recaptcha perhaps?

  • Great find.i had taken Look at the profile page and did not make that connection – Donald Lobo Jun 4 '15 at 15:42
  • I was having this problem before I turned recaptcha on. But I went ahead and turned off recaptcha. Now the module works sometimes, other times it does the same thing - no save and kick back to the frontpage. – Devin Jun 5 '15 at 16:26
  • From the Error Log - May 29 23:41:35 [info] $backTrace = #0 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(363): CRM_Core_Error::backtrace("backTrace", TRUE) #1 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Utils/Type.php(362): CRM_Core_Error::fatal("One of parameters (value: ) is not of the type Integer") – Devin Jun 5 '15 at 16:39
  • #2 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Core/DAO.php(1247): CRM_Utils_Type::validate(NULL, "Integer") #3 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Core/DAO.php(1166): CRM_Core_DAO::composeQuery("\nSELECT module,is_reserved\n FROM civicrm_uf_group\n LEFT JOIN civicrm_uf_...", (Array:1), TRUE) – Devin Jun 5 '15 at 16:39
  • #4 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Profile/Form/Edit.php(122): CRM_Core_DAO::executeQuery("\nSELECT module,is_reserved\n FROM civicrm_uf_group\n LEFT JOIN civicrm_uf_...", (Array:1)) #5 /var/www/vhosts/tremololabs.com/httpdocs/clients/IREHRTEST/administrator/components/com_civicrm/civicrm/CRM/Core/Form.php(455): CRM_Profile_Form_Edit->preProcess() – Devin Jun 5 '15 at 16:39
0

I think I've tracked down the problem on my site to the uk.co.vedaconsulting Mailchimp plugin. Removing that seems to fix my issue on my test server, making my hack of embedding an iframe unnecessary. Hopefully it also fixes my timeout problem described at How do I make profile submissions more reliable, or at least not silently fail?

I need to confirm that this fixes the problem on our production server.

Devin, are you using the Mailchimp extension? Or any others you can try disabling?

  • Nope, i was wrong...misled by confusions in reloading pages and accidentally making it work with the background-loaded embedded form hack. Disabling Mailchimp or other plugins does not in fact change anything. See my other question for the workaround hack I've settled on. – Norris Sep 22 '15 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.