3

I was updating a site adding new relationships for cases, and relabelling old relationships to make more sense in case context.

What I've since found is that the updates to the relationship table don't automatically feed thru to the case relationships/ settings.

Fast forward a couple of months and it turns out that the case manager is no longer showing in the case dashboard.

I've either changed the designated case manager relationship, or relabelled the relationship and it is not being picked up by the dashboard.

Can anyone point me to where I'd find the case type setting file in the backend so i can start diagnosing what I've relabelled and what relationship the case expects to see as manager?

1

Check the name_a_b and/or name_b_a fields in the database table civicrm_relationship_type. Check that they match the <name> entries in the <CaseRoles> section in the xml files in <path_to_civicrm>/templates/CRM/Case/xml/configuration. Depending on your version or upgrade history the xml definition might be in the civicrm_case_type table in the definition field.

  • Thank you Demerit, that got me to the info I wanted. The xml definition is in the civicrm_case_type table. As a hyperlink. I can view the definition from there (opening in notepad). The settings in there tally with the settings from Admin>CiviCase>Casetypes edit settings <CaseRoles> Includes all the relationship types I'd expect. The one I want is marked as manager Relationship names/ labels correspond to relationship table. But on the case dashboard the wrong relationship type is still being picked up as case manager. Will post up a new question. – Craig Almond Aug 21 '18 at 14:36
  • 1
    Not posting a new question. This post suggested itself as I was posting civicrm.stackexchange.com/questions/18652/… Dashboard does not update to reflect changes in case manager settings once cases of case type created. xmlprocessor php file needs amending situation still there in 5.3.1 – Craig Almond Aug 21 '18 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.