1

I've built two profiles to create user accounts 1) Volunteers Adds contacts to volunteers group to sync with volunteer role 2) Volunteer Managerss Adds contacts to volunteer managers group to sync with volunteer managers role

Both worked fine last week

Went to review the Vol manager profile today and none of the user acct fields (choose username, enterpassword etc) were visible on the profile. But the fields still showed in the volunteer profile.

Have been tinkering with profile settings, saving and unsaving. Can't make them reappear.

Both profiles have same settings: profiles set as standalone form. acct creation required checked. Site visitors can create own accounts set in drupal config. anon users can use profiles in create mode in drupal permissions.

Went to look at the volunteer profile a few minutes ago, and although it was showing user fields earlier, now the fields are missing from both profiles.

Gah!

Any help/ suggestion will be much appreciated!

drupal 7.59 civi 5.3.1

3

You will need to check few things

  1. Check if the profile has create user account option enabled.

  2. Check drupal settings if Anonymous user is allowed to create account(Configuration >> Account Settings).

  3. Make sure your profile has email field and is primary or uses default location type

  • Hi Pradeep, yup both options in place. And anon user can use profile in create permission in place. Will edit question to make that a bit clearer. – Craig Almond Aug 23 '18 at 15:13
  • 1
    just updated my answer to add one more check – Pradeep Nayak Aug 23 '18 at 15:18
  • Aaaaah, Both profiles have first name, last name and email fields marked. I have switched the email locations round on the profiles (home to main), (main to work). Could that have affected the user log in in anyway? – Craig Almond Aug 23 '18 at 15:41
  • Thank you. Looks like email- location has to be set to site default for user acct creation to work. Who'd'a'thunkit? – Craig Almond Aug 23 '18 at 16:26
  • I guess it should be primary email. I will update my answer, so can you mark this solution as answered if this solves your problem? – Pradeep Nayak Aug 23 '18 at 16:39
1

Thanks to Pradeep's intervention I've reinstated the user acct fields.

The site default location is home. So when first creating the profiles they defaulted to email location= home.

As I was making changes to the system I though semantically "Main" was a better location and updated the profile emails fields accordingly.

That's what broke the profiles.

re-editing the fields and setting location = home, gives me working user acct profiles.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.