4

I'm needed to add a scenario where a specific user role has access to edit/update activities they are assigned but access nothing else in civi. What is the best way to do this?

edit: after the discussion with petednz we found that there is an issue with assigned activities showing up on the contact dashboard.

edit2: filed jira issue at https://issues.civicrm.org/jira/browse/CRM-16557

2

Maybe over complicating things a lot here. But assuming you have confirmed this isn't possible directly via 'permissions' and the users Contact Dashboard, I would try the following in Drupal. Build an Activities based Views block which uses Contextual Filter and Views 'relationships' (to get the Activity assignee) which will show the user 'their Activities'. Assuming that gives you the list you want, then add a link to each Activity in the View that jumps them to a Webform-CiviCRM with the activity ID in the URL. That might be getting you close.

  • I thought I would try to confirm that Contact Dashboard doesn't get you anywhere. On Demo site I assigned an Activity to myself, went to my Dashboard (where I had previously set Activities to show) and nada. It shows "Your Assigned Activities: There are no scheduled activities assigned to you." which seems incorrect to me. d46.demo.civicrm.org/civicrm/user?reset=1 does not show the activity i assigned to d46.demo.civicrm.org/civicrm/contact/view?reset=1&cid=202 – petednz - fuzion May 23 '15 at 21:21
  • Yeah that's what's happening on my own site. I've gone through the permissions and enabled anything that might cause that and still nothing. If the contact dashboard would show the activities that are assigned to the user then allow the user to click on it and edit it that would work perfect. – frTommy May 23 '15 at 22:12
  • Any idea @petednz what's causing that? I can't figure it out. – frTommy May 24 '15 at 18:02
  • I checked on a 4.4.15 site and it works as expected so perhaps you can file a ticket in JIRA if one isn't already there – petednz - fuzion May 24 '15 at 21:21
1

This was a regression bug from 4.4 to 4.5. I have submitted a fix for the next release (4.6.4).

See https://issues.civicrm.org/jira/browse/CRM-16557

  • I applied the changes but still doesn't fix it. Just to verify that i have the permissions set correctly can you tell me what permissions are needed for a user in this situation? – frTommy May 26 '15 at 2:12
  • None that I know of. Reading the code, it looks like it skips permission checks entirely for the activity results. – Coleman May 26 '15 at 2:17
  • Then that did not fix the problem. I applied it and still no activities assigned to the user are showing up. – frTommy May 26 '15 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.