0

I have installed Civi 4.2.19 in Joomla 2.5, to upgrade the 4.1.1 version. I cleared all cache and then tried to run the database update. I got this fatal error:

Fatal error: require_once(): Failed opening required 'CRM/Upgrade/Incremental/php/FourFix.php' (include_path='/home/xxxxx/public_html/j25/media/civicrm/custom/code:.:/home/xxxxx/public_html/j25/administrator/components/com_civicrm/civicrm:/home/xxxxx/public_html/j25/administrator/components/com_civicrm/civicrm/packages:.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/xxxxx/public_html/j25/administrator/components/com_civicrm/civicrm/CRM/Core/ClassLoader.php on line 126

It's referencing file "FourFix.php" which does not exist. I'm stuck and can't continue. I tried updating to 4.4.21, then the database update. Same result. Anyone able to help??

  • Why not 5.3.1?? – Pradeep Nayak Aug 28 '18 at 23:44
  • I had read somewhere that for Joomla, I needed to first upgrade to 4.2.19 then I could go from there. Are you saying that is not true and I should go ahead and install a later build? – DirectTech Aug 29 '18 at 3:25
  • The end result should be the same whether you upgrade directly to the latest release or go through a few intermediate versions. Troubleshooting can be easier with smaller steps, but you can also hit unnecessary problems in intermediate releases that are fixed in later ones. If you don't know the system's history then before doing any upgrades, I'd check the installed files against a fresh download of that version to see if there have been any local changes. Most important thing is to take backups of files and db before starting. – Aidan Aug 29 '18 at 11:07
1

Just found the issue. In the /CRM/Upgrade/Form.php file, I found this:

static $_numberMap = array( 0 => 'Zero', 1 => 'One', 2 => 'Two', 3 => 'Three', 4 => 'Four', 5 => 'Five', 6 => 'Fix', 7 => 'Seven', 8 => 'Eight', 9 => 'Nine', );

You can see 'Fix' where it should be 'Six'. I corrected that then was able to move forward.

ALSO, I found that I had to install version 4.2.0 before I could install 4.2.19 successfully. I also upgraded to 4.1.6 prior to 4.2.0. Not sure if that was required, but I was seeing what worked.

Hopefully this will help the next poor soul that gets stuck upgrading a 6 year old CiviCRM build in Joomla!

  • It's not clear to me why it is even trying to find FourFix or FourSix if you are upgrading to 4.2.19 or 4.4.21 That would be used when trying to go to 4.6 or later. However, it seems you have made progress! What version are you at now? You might also want to look at upgrading Joomla and php... – Aidan Aug 29 '18 at 11:12
  • I was looking for FourFix because the errors pointed to it. The code sample seen above shows the typo that was causing the problem and where "Fix" came from to begin with. This is all being updated as a part of moving the site to the latest Joomla also. Fun. :) – DirectTech Aug 31 '18 at 4:37
  • I got to 4.2.19. I can't get a database update to work form 4.3.0 or later. Been fighting for a while now. Going to start a new post for it as it seems like a new issue. – DirectTech Sep 4 '18 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.