When I insert a shortcode for my contribution page into a page on WordPress, the text on the page gets duplicated and I can't figure out why.

I'm not sure if this is a CiviCRM issue or a WP issue for my theme, but if I remove the shortcode it doesn't do that, so I figured this is a good place to start.

You can see it here: http://www.gardensedge.org/support/

  • When you say the text is "on the page", do you mean the Wordpress page, the CiviCRM contribution page, or both? Are you able to replicate the problem on the Wordpress demo site at demo.civicrm.org? May 24, 2015 at 0:19
  • The only way I have been able to figure out to do that is to put this line into my functions.php file: add_filter( 'jetpack_enable_open_graph', '__return_false' ); and it doesn't seem to be working. Do you know of another way to disable Open Graph? Note, I also found this, which doesn't seem to work either: // remove jetpack open graph tags remove_action('wp_head','jetpack_og_tags');
    – Terra
    May 27, 2015 at 14:23

1 Answer 1


Try disabling the Jetpack Open Graph component and see if the problem persists.

  • I tried that, as well as fully disabling JetPack, but to no avail, so it doesn't seem to be any of the JetPack components.
    – Terra
    Jun 1, 2015 at 22:25
  • I also cut the CiviCRM shortcode for the CiviContribute page and pasted the code into a different page just to make sure it was related to that shortcode specifically and it definitely is.
    – Terra
    Jun 1, 2015 at 22:36
  • I assume you've tried disabling your other plugins to see if it's caused by one of them? Jun 10, 2015 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.