I have just upgraded from CiviCRM 4.6 to 5.4.1. In events and mailings the description boxes are missing CKEditor. I have tried clearing caches and I have installed I10N for GB as some. I have also looked for the Access CiviCRM permission and that is selected for Events.

I'm stumped and now all our events have raw html in the descriptions. Can anyone help please.


  • In the console I am getting the error: Loading failed for the <script> with source “home/ficmin/drupal/sites/all/modules/civicrm/js/wysiwyg/… – Gareth Aug 31 '18 at 15:43
  • is it a multilingual site? Can you check resource URL and Directory path? – Pradeep Nayak Aug 31 '18 at 16:11
  • It sounds like maybe that's the wrong path - can you confirm CKEditor is at that path? Also, this isn't a direct answer, but important to know: civicrm.org/blog/colemanw/big-changes-to-wysiwyg-editing-in-47 – Jon G - Megaphone Tech Aug 31 '18 at 16:12
  • Legacy setup has left us with a number of symlinks going to public_html and some strange paths (I will need to sort these in the future). I removed one and re-added and also set to 755 and it now works. – Gareth Aug 31 '18 at 16:45
  • Gareth can you add this as an answer so others can know how you solved it? – Coleman Aug 31 '18 at 23:25


Our previous hosts had set up symlinks so that an upgrade could be tested and quickly swapped over. With the latest version, 5.4.1 symlinks break ckeditor. I removed symlinks and changed [cms.root] to /home/USER/public_html. I corrected all the paths under Resource URLs & Directories. I also cleared out cache as if we were moving to a new server. CKEditor is working perfectly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.