1

We're using 5.4.1 on Wordpress 4.9.8 with php 5.6.34.

The following issue seems to have started with 5.3.x and we still cannot solve it.

When we create an activity, we include:

  1. a hyperlink in the details
  2. a status using the dropdown box

All works as it should when we create an activity. However, when we choose to edit it (wrong hyperlink, change the status, etc.), we are unable to do so.

  1. The hyperlink properties box does not come up when clicked
  2. The dropdown box will not come up when status is clicked

In both cases the anticipated pop-up windows show up behind the active window, but -- in addition to being the wrong behavior -- they still don't work.

My work-around is to edit in HTML (vs WYSIWYG) and changing statuses via searches and applying changes by profile. But this is time-consuming and not all of our team can easily do it. And it's not how Civi is supposed to work.

We're using Chrome/Windows. I thought we solved it by clearing Chrome's cache (but the result is sporadic at best). We've also tried Firefox with same issue.

Does anyone know what's going on here?

Thanks!

P.S. The correct functionality does appear to be present in 5.6.alpha1 in the demo sandbox. Can anyone verify if this is a known bug? If not, I'm concerned the issue may be our database rather than Civi.

Here are screen shots showing correct behavior with creating activities. Note that the dropdown box for assigning status and hyperlink box for providing link details pop up in foreground and can be completed and saved:

New Activity creation with expected status dropdown pick list New Activity creation with expected hyperlink box when adding link

Here are screenshots of the incorrect behavior after saving this activity and attempting to edit it. Note the dropdown and hyperlink dialog occur behind the activity screen (I've move the Activity screen to reveal them). Even after revealing them, they do not function.

[Nonfunctional and eclipsed status dropdown box when edit of saved activity is attempted[3] Nonfunctional and eclipsed hyperlink dialog box when edit of saved activity is attempted

  • Can you add some screenshot of how it looks on the edit screen? – jitendra - fuzion Sep 9 '18 at 6:01
  • Here are two screen shots showing proper behavior for creating an activity. Note the correct pop-up of the drop-down status menu and html menu: – slbradio Sep 9 '18 at 18:22
  • One significant new bit of information: The above errors seem to be limited to attempts to edit activities from an activity list resulting from a search. If I instead edit from an activity list resulting from a report, I'm getting the proper behavior. Editing from searches yields a popup for the activity and then a popup statrus (or HTML edit). Editing from reports eliminates the first popup as expanding the activity causes it to take over the field. – slbradio Sep 9 '18 at 19:18
  • Editing timed out. Apologies for extra post, but to be clear: The errors seem to be limited to edits of activities opened from a search. If edited from a report, I'm getting the proper behavior. Because edits from searches make the activity itself "pop up" when clicked (adds and edits from Reports show activities in full screen when clicked), the behavior I'm noticing is when we try to pop-up a dropdown or HTML dialog within a situation where the activity is already shown as a popup! I know we used to be able to edit from search results...this is what I think has changed. – slbradio Sep 9 '18 at 19:28
  • Any chance you can see if any javascript errors show when you're trying to access these pop ups? – RayWright Sep 10 '18 at 14:24
1

I'm happy to report that the original issue was resolved with an update to 5.5.1. With this update made, the errors illustrated in my original post are no longer occurring.

Because we've long used CiviCRM without this error and first noticed it with 4.7.31 (and consistently with subsequent upgrades), we believe that this new upgrade has returned the functionality enabling us to again edit activities from a popup window opened from search results.

@RayWright, thank you for suggesting the java review and screenshots which helped us see that the issue was limited to "pop up" edit windows (i.e., activities opened from searches) rather than full-screen edits (i.e.,activities opened from reports). The latter may especially be helpful as a workaround if future users see this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.