2

Custom fields for participants in Civi are not being presented for addition to Drupal Webform. Event registration is selected and working but the custom field set for participants are not showing up for placement on the webform. Is there a reason that they are not included for webform usage?

enter image description here

1
  • Do you mean a custom field specifically linked to a participant & not a contact? Custom fields linked to a contact are working on an event webform, at least on 5.1.2.
    – Andy Clark
    Sep 12, 2018 at 19:43

1 Answer 1

1

Thank you for asking. This should work - and I just double checked and it is working on one of our live projects:

Webform CiviCRM config: enter image description here

And the CiviCRM config [On-line and Custom Fields are on the Participants entity]. enter image description here

Is it perhaps possible that you've (accidentally) restricted these Custom fields to certain Events only?

2
  • The problem seems to be a display issue. When I selected the restore button (upper right side along with select all, select none), they all showed up. Thanks for responding as it was helpful to know that it should work.
    – Dave T
    Sep 13, 2018 at 20:55
  • From what I can see custom fields linked to participant records only show up if they are not constrained to specific events or event types, regardless as to whether you might be filtering the events available to the webform to match.
    – Graham
    Jun 14, 2022 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.