1

I'm relatively new to CiviCRM and am trying to get a client set up with the platform. I like it overall, it seems much more usable than most I've touched in the past.

All seemed to be going well until late last week. I had it basically set up on a third-party server. There might have been a resource path issue, or it might be a known testing bug (probably the latter).

Somewhere in there an upgrade was called for by Civi and I decided to give it a try. It appeared to work, but after the DB upgrade step I couldn't get to any Civi pages. I had to completely blow away Civi and start again to get anything displayed. Restoring the db from Backup brought me back to a somewhat usable state, but it wants to upgrade the db. I've tried a couple times with the same result.

I'm limping along right now with a db that says it needs to upgrade, but otherwise seems to work.

Looking around on the forums here, it seems like maybe I should be using an older version. The website seemed to be strongly steering me to 5.* so I assumed it was stable. I see here, people using 4.7 which I didn't even see on the website (all seemed to be 5.* and 4.6.*).

Any thoughts on either fixing this 5.5.1 problem or if I should be finding and running 4.7?

  • Did you check CiviCRM logs to see for any error? – Pradeep Nayak Sep 14 '18 at 19:04
  • There's a report on the WordPress Mattermost channel that non-shortcode URLs have an issue on 5.5.1. If so that's a major problem and will likely be sorted very shortly. – Andrew West Sep 14 '18 at 19:06
  • update: there haven't been any other reports on this since, so I don't think it's an issue. – Andrew West Sep 21 '18 at 8:56
0

People using 4.7 are out of date - 4.7 is end-of-life. You should definitely go with 5.x for most use cases.

I would check your error logs in the ConfigAndLog directory - then come back here and edit your question to add the relevant logs. In general, there's a troubleshooting page in the documentation, but most of the suggestions aren't applicable to upgrade failures.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.