1

I'm getting this error pretty regularly lately, specifically after upgrading from 5.4.0 to 5.4.1: The CiviCRM public extensions directory at https://civicrm.org/extdir/ver=5.4.1|cms=WordPress could not be contacted - please check your webserver can make external HTTP requests or contact CiviCRM team on CiviCRM forum.

My dashboard is also pretty frequently showing "Sorry but we are unable to provide this at the moment"

Weird thing is I have another test instance on 5.4.1 and it's working fine. (Both instances in question are running on Amazon Lightsail.)

Are there maybe some directory permissions or something along those lines I need to check? I did some basic checking between the test instance that's working and the one that isn't and didn't see anything obvious.

Thanks for any ideas anyone has.

3

The dashboard issue is a known issue in CiviCRM 5.4. The latest version of CiviCRM solves this. I'm not sure if that would also affect the extensions directory though. Please comment on this answer if it does though!

| improve this answer | |
  • Thanks! The issue with the extensions directory DID turn out to be a permissions issue. If you're using the Bitnami distro of WordPress on Lightsail most of the directories are owned by bitnami:daemon, but specifically where the wp-content/uploads/civicrm directory is concerned it seems that needs to be owned by daemon:daemon even though bitnami is in the daemon group and that group had rw access. Thanks again for leeting me know on the dashboard! – Matt Woodward Sep 15 '18 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.