1

I am building out my first front end form and the total amount field is not populating. We are running on Joomla 3.8.12 and CiviCRM 5.5.1.

http://dev.victoryliving.org/index.php/donate

Please help, thank you!

enter image description here

1

From what I can see, it looks like you're not using a price set - so it's actually a mystery why "Total Amount" appears in the first place. You don't have anything to total! I just confirmed on a test site that I don't normally see "Total Amount" on a contribution page that doesn't require it.

If you could edit your question to display a screenshot of the price configuration for this contribution page, perhaps someone will notice something amiss.

  • I added a photo. I had a price set I tried to test, but deleted it and unchecked the box for it when I realized it wasn't what I needed. So not sure why that did not go away. – Mary Sep 20 '18 at 3:01
  • Thanks for the screenshot and details! It sounds like there might be a bug that exists when you enable, then disable the price set. Do you have a way to run SQL? Could you update the query SELECT is_quick_config FROM civicrm_contribution_page ccp JOIN civicrm_price_set_entity cpse ON ccp.id = cpse.entity_id AND entity_table = 'civicrm_contribution_page' JOIN civicrm_price_set cps ON cpse.price_set_id = cps.id WHERE ccp.id = x where that final "x" is the id of the contribution page in question? The id is "1" if it's your first contribution page. – Jon G - Megaphone Tech Sep 20 '18 at 3:06
  • I tried running it however the result shows: Showing rows 0 - 0 (1 total, Query took 0.0007 seconds.) and it does not appear to have made a difference – Mary Sep 20 '18 at 3:33
  • That command wouldn't have changed anything - it's just a diagnostic. And I don't think it's possible to have zero rows there. Maybe the contribution page ID is off? To explain further - there's a record in civicrm_price_set that corresponds to your price options (even if you're NOT using price sets). The is_quick_config will be set to 1 for a "real" price set, and "0" if you're using the "Fixed Contribution Options". I'm wondering if somehow your price set has a 1 where it should be a 0. – Jon G - Megaphone Tech Sep 20 '18 at 13:46
  • Ah ok that makes sense. Hmm, maybe the system still sees 1 even thought I deleted the one I made and unchecked the box? And the contribution id is correct. Only ever made the 1 page and the id is 1. I may just have to remake the page and see if that fixes it – Mary Sep 20 '18 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.