1

enter image description hereBeen using Xampp and doing backups for years, it's Xampp portable, so solved my timeout issues a long time ago...

All other sites on this Xampp local work fine, using windows 10, 64, and Drupal7/CIVI CRM.

This worked fine, but just stopped suddendly.

I looked a the error log , and Drupal doesn't even have an "admin/config/system/backup_migrate" directory, am I missing something here?

Now getting these errors:

The website encountered an unexpected error. Please try again later.

Log shows this:

Type    php
Date    Friday, September 28, 2018 - 16:50
User    1
Location    http://localhost/crm4/admin/config/system/backup_migrate
Referrer    http://localhost/crm4/admin/config/system/backup_migrate
Message PDOException: SQLSTATE[42S02]: Base table or view not found: 1932 Table 'crm4.civicrm_value_files_8' doesn't exist in engine: SHOW CREATE VIEW `civicrm_value_files_8`; Array ( ) in backup_migrate_source_db_mysql->query() (line 435 of C:\Core\XAMPP_2018\htdocs\crm4\sites\all\modules\backup_migrate\includes\sources.db.mysql.inc).

strong text**

1

To clear up the smaller issue - Drupal, like most modern web apps, will not have a directory corresponding to most of its URLs. It will use redirects (defined in the webroot .htaccess file) to map URLs to a dynamically-generated page which doesn't exist on disk.

To speak to your primary issue - it sounds like you've got a MySQL view in your database. CiviCRM doesn't typically create MySQL views, though there are some exceptions (I believe CiviCase might use them). There are also sometimes reasons to create them manually - for instance, I created one for a client so CiviCRM could integrate with software that produces membership cards.

You have a view that references data that no longer exists. It seems someone recently deleted a custom field group called "Files" with a custom group id of 8. You have a MySQL view built in part from the table that holds that data. The table is gone, so the view is broken.

Most likely, if the custom group is deleted, you no longer need the view, and it's safe to simply delete the view using PhpMyAdmin or similar. However, it may be worth exploring whether that custom field group was deleted intentionally.

  • Yes, excellent advice, that was my problem. I fixed it by deleting the offending table, but I didn't know what I was doing...kind of sweated when I clicked on "drop"...but it worked, and in retrospect you explained what I actually did, and now I understand better, cheers ;) – Bruno Vincent Sep 30 '18 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.