1

When composing an email activity, when Shoreditch is installed (even though CiviCRM admin theme is Garland) if I want to put a link into the email, the dialog box breaks. See attached screenshot. The Link Type and Protocol dropdowns get detached from the dialog box.

Have tested on two sites both running latest versions of extension and CiviCRM.

Changing the admin theme does not fix the issue. Disabling the Shoreditch theme fixes the issue.

Would be nice to fix as the Shoreditch theme is needed for the Mosaico extension.

enter image description here

3

I just tested with Shoreditch activated as CiviCRM custom css, with seven as admin theme and CK Editor worked just fine.

I also tried to replicate your setup, using Drupal 7, Shoreditch 0.1-alpha25, Civi 5.5.3, Garland as CiviCRM admin theme, and custom CSS URL as other instead of shoreditch and I was unable to replicate your issue.

It seems that you are not actually using shoreditch as your civicrm theme. What is listed as your theme when you look at Administer - System Settings - Resource URLs - Custom CSS URL? Do you typically use Garland as an Admin theme? I found that the most compatible theme with shoreditch (when used as Custom CSS) is Seven, as I ran into trouble with other admin themes such as adminimal.

|improve this answer|||||
  • 1
    I was using Shoreditch 0.1-alpha18. When I installed the Shoreditch 0.1-alpha25 version everything works as intended. Thanks for testing – Tony Horrocks Oct 3 '18 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.